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Preface
CATIA Version 5 Structure Design allows you to quickly model linear and curved
structures, and plates using standard or user-defined sections. It addresses foundation
and tooling design.

As a scalable product, CATIA-Structure Design can be used with other CATIA Version
5 products such as CATIA-Part Design, CATIA-Assembly Design, CATIA-Sheetmetal
Design, and CATIA-Generative Drafting.

 

Using This Guide
More Information



Using This Guide
This book is intended to help you become quickly familiar with CATIA Structure Design.
You should already be accustomed with basic CATIA Version 5 concepts such as
document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the
step-by-step Getting Started tutorial.

Basic Task and Advanced Task sections present the main capabilities in the form of
user tasks. It may be a good idea to take a look at the section describing the
workbench menus and toolbars.
 

 

 



More Information
Prior to reading this book, we recommend that you read the CATIA Version 5
Infrastructure User's Guide.

The CATIA-Part Design User's Guide, CATIA-Assembly Design, CATIA-Sheetmetal
Design and CATIA-Generative Drafting User's Guide may also prove useful.

Click to find out more about Conventions used in this guide.

 

 

 

 



Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help
you recognize and understand important concepts and specifications. The following
text conventions may be used:
       The titles of CATIA documents appear in this manner throughout the text.
       File -> New identifies the commands to be used.

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button, whenever you read

Select (menus, commands, geometry in graphics area, ...)
Click (icons, dialog box buttons, tabs...)
Double-click
Shift-click
Ctrl-click
Check (check boxes)
Drag
Drag and drop (icons onto objects, objects onto objects)

Drag
Move

Right-click (to select contextual menu)

Graphic conventions are denoted as follows:

indicates the estimated time to accomplish a task.

indicates a target of a task.

indicates the prerequisites.

indicates the scenario of a task.

indicates tips



indicates a warning.

indicates information.

indicates the end of a task.

indicates functionalities that are new or enhanced with this Release.
Enhancements can also be identified by a blue-colored background in the
left-hand margin.

 



What's New?
Enhanced: When creating plates, you can now use the Sketcher to define the contour

 



Getting Started
This tutorial will guide you step-by-step through your first Structure Design
session, allowing you to get acquainted with the product.

You will need a CATIA Version 5 session and should be familiar with basic
concepts such as document windows, standard and view toolbars.

You should be able to complete this tutorial in about 15 minutes.
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Setting Up Your Session
This first task shows you how to enter the Structure Design workbench and set
up your V5 session.
1. Select File -> Open then select the GettingStarted.CATProduct document

from the samples directory.
2. Select Mechanical Design ->Structure Design from the Start menu.

The Structure Design workbench is displayed.
3. Switch to Design Mode (Edit -> Representations ).

The document contains wireframe construction elements that will help you
build the following foundation:

4. To ensure associativity between the structures you are going to create and
the grid used as a construction aid, set the following options:

Select Tools -> Options from the menu bar
Click Mechanical Design -> Part Design in the left-hand box of the
Options dialog box
Click the General tab
Check Keep link with selected object and Synchronize all external
references.

5. Click Mechanical Design -> Structure Design in the left-hand box of the
Options dialog box and select the Structure Design tab, then set member
and plate material to Steel.

file:///E|/WWW/MTNDOCR5/StdEnglish/stdug.doc/src/samples/GettingStarted.CATProduct


6. For access to available sections as well as to sample standard catalog
sections, set the following options in the Structure Design tab:

Enter the path of the directory containing sample standard catalog
sections in the Directory field under Catalog storage:
installation_folder/startup/components/structuralcatalogs
For more information on the installation folder, see the CATIA
Infrastructure User's Guide.
Enter e:\tmp in the Directory field under Section storage to identify
the path of the directory containing available sections

7. Click OK in the Options dialog box when done.

 

 

 



Creating Support Columns
 

This task shows you how to create the four support columns of your structure. Columns use standard section
IPE200 with a gravity anchor point.
1. Double-click the Member  icon.

The Member Definition and Point Definition dialog boxes appear.

Double-clicking keeps the dialog box open letting you can create several columns.

2. Close the Point Definition dialog box.
3. Load the standard section, IPE200, that you will need:

In the Section list, select Other section...

The Catalogs dialog box listing the various
catalogs available is displayed.
Select the OTUA catalog.
In the Family box, select the IPE type.
In the Section box, select section IPE200.
Click OK.

The Section list in the Member Definition dialog box is updated.

4. Keep default options defining member type, anchor point and orientation.



5. In the Direction box list, select Parallel to the Z axis.
6. Select the start point of your column.
7. Select the end point of your column.

The column is created in the geometry area and identified in the specification tree.

In this case where a support (grid line) coincides with the start and end points used to create the column,
you can also use the Member on Support command.

8. Repeat to create the other three columns.
Your structure now looks like this:

 

  

 



Creating a Plate

This task shows you how to create a plate on top of the support columns.

1. Click the Plate  icon.

The Plate Definition dialog
box appears.

2. Enter the plate thickness, for example 100mm.
3. Select the grid plane

as support plane.

4. Select the ends of linear members to define the contour of the plate:

Note: The system shows you a preview to guide you when creating the
plate. You need only   select the ends of three members, the system
closes the contour for you.



5. Select the arrow to invert the orientation of the thickness.
6. Click OK to create the plate.

Your structure now looks like this:

 

  

 



Bracing Your Structure

This task shows you how to brace both ends of your structure.

1. Double-click the Member  icon.

The Member Definition dialog box appears. Double-clicking keeps the dialog box open
letting you can create several braces.

2. In the Type list, select V-Brace.
3. In the Section list, select IPE200.
4. In the Anchor point list, select Gravity.
5. In the Direction box list, select Unspecified.
6. Select the top end of the first column.
7. Select the bottom end of the opposite column.

The first part of the brace is created.

8. Select the bottom end of first column.

9. Select the top end of opposite column.

The brace at this end of the structure is finished.

10. Repeat for the other end of the structure.

Your structure now looks like this:

 

  

 



Creating a Walkway

This task shows you how to create the linear members making up a walkway.

The Linear Member Definition dialog box is still displayed.

1. In the Type list, select Beam.  

2. In the Section list, select IPE200.

3. In the Anchor point list, select Gravity top.

4. In the Direction list, select Parallel to the X-axis.
5. Click the Length checkbox and enter 2000 in the Length box.
6. Select column 1 and indicate to identify the positive

direction:

The first support beam is created.

7. Select column 4 and indicate to identify the positive
direction:

The second support beam is created.

8. In the Linear Member Definition dialog box, change the direction to Parallel to the xy plane.
9. Uncheck the Length checkbox.
10. Click the Offset checkbox and enter 2000.
11. Select the two support beams you just created:

The first connecting beam is created.



Be careful where you select the two beams. The system determines the end nearest the selection point to define
the start and end points of the beam you want to create.

12.. Select the two support beams again, this time at the other end:

The second connecting beam is created.

Note: This second beam is needed to create the infills and complete the walkway.

You are now ready to brace your walkway.
13. In the Type list, select V-Brace.

14. Keep the same section, IPE200.

15. In the Anchor point list, select Gravity.

16. In the Orientation box, use to arrows to change the
angle to 90 degrees.

17. In the Direction list, select Parallel to XZ plane.

18. Uncheck the Offset checkbox.

19. Select the bottom end of column 1.
20. Select the far end of the first beam created.
21. Repeat for the other end of the walkway.
22. Click the Member  icon to exit the command.

Your structure now looks like this:

 



  

 



Creating Infills

This task shows how to create infills to complete the walkway and your structure.

1. Click the Infill   icon.

The Infill Definition dialog box
appears.

2. In the Type list, select Beam.

3. In the Section list, select IPE200.

4. In the Anchor point list, select Top
center.

5. Set the Orientation back to 0deg.

6. In the Number box, use the
arrows to change the number of
infills to 4.

7. Keep the default options in the
Spacing boxes.

8. Select the two connecting beams.
Important: Make sure you select the entire definition of the beam.

9. Click OK to create the infills.

Infills are created and have  the characteristics defined in the Infill Definition dialog box.

Infills are added to the specification tree.

Your structure now looks like this:



 

  

 



Making Design Changes
You discover that your structure interferes with the dismantling and maintenance of
neighbouring parts. It needs to be shortened slightly and this can be done without
adversely affecting your design.
This task shows you how to use the associativity between the members and plate
created and the construction grid to adjust the length of your structure.
1. Double-click the plane (highlighted below) at the end of the structure twice to edit it:

Note: On the first double-click, you enter the Part Design workbench.

On the second double-click, the Plane Definition dialog box appears.



2. Drag the plane to the new position or enter a shorter offset distance in the dialog box,
for example 2500mm.

3. Click OK when done.

The grid is updated. Now you can update the structure.

4. Double-click the root product in the specification tree.
5. If the Update  icon is active, click to update.

The structure is updated.
Your structure now looks like this:



 

To ensure associativity between the structures you create and the grid used as a
construction aid, you must check the following options (Tools -> Options...) before
creating your structures:

Keep link with selected object and Synchronize all external references for
update in the General tab under Mechanical Design -> Part Design in the
Options dialog box.

 

This concludes the getting started step-by-step scenario.

You should now go to the basic task section of this guide. This steps you through
basic procedures, letting you get the most out of this product.

 

 

 



Basic Tasks
The basic tasks you will perform in the Structure Design workbench involve creating
linear and curved structures, and plates using standard or user-defined sections,
modifying structures, specifying structure joints, translating and rotating structures, as
well as creating construction grids to assist you create structures.

 

Creating Structures
Modifying, Joining & Moving

Creating a Grid

 



Creating Structures
CATIA - Structure Design allows you to create linear and curved structures, and
plates using standard or user-defined sections.

Do not forget to switch to Design Mode (Edit -> Representations -> Design
Mode) to create structures.           

Double-clicking commands keeps dialog boxes open and lets you create more
than one structure at any one time.

Associativity:

To ensure associativity between the structures you create and any underlying
wireframe geometry used as construction geometry, you must check the
following options (Tools -> Options...) before creating your structures:

Keep link with selected object and Synchronize all external references
for update in the General tab under Mechanical Design -> Part Design
in the Options dialog box.

 
Access sections: Select Other section... in the Section box list then choose
the appropriate catalog or simply select a user-defined section in the
Section box list
Create linear members: Set parameters in the Member Definition dialog box
then define where the member starts and ends

Create infills: Set parameters in the Infill dialog box then select the two
structures between which you want to create infills

Create members on supports: Set parameters in the Member on Support
dialog box then select the support

Create plates: Set parameters in the Plate Definition dialog box, select a
support then define the contour of the plate

Create end plates: Set parameters in the End Plate Definition dialog box,
select the end of the structure at which you want to place the end plate

 
 



 

 



Accessing Sections
Sections used to create structures can be:

Standard catalog sections

Samples of standard catalogs are supplied with the product. 
Sections in these catalogs are parametric sketches associated with
design tables (CSV-type Excel files).
User-defined sections.

All sections are accessed via the Section list in Linear Member Definition, Infill
Definition or Member on Support dialog boxes.
This task shows how to make standard catalog and user-defined sections
available.

No sample document is provided.

Accessing standard catalog sections

1. Select Other section... in the Section box list of the Linear Member
Definition, Infill Definition or Member on Support dialog box.
The Catalogs dialog
box listing the various
catalogs available is
displayed.

2. In the Catalog box,
select the catalog of
interest, for example
AISC.

3. In the Family box,
select the type of
interest, for example C.

4. In the Section box,
select the section of
interest.

5. Click Apply in the
dialog box.

6. Select as many
sections as desired,
clicking Apply each
time.



The Section list of the appropriate Definition dialog box is updated with the
selected section(s).

Note: Catalog sections added to the list are saved in the directory defined
in the Section storage box of the Structure Design tab in the Options
dialog box (Tools  -> Options -> Mechanical Design) and can,
subsequently, be accessed directly in the Section list.

User-defined sections

User-defined sections are of two types:
Parametric sections stored in a user catalog

User catalog sections are accessed via the Other section... option in
the Section box of the dialog box.
Resolved sections stored directly in the directory defined in the Section
storage box of the Structure Design tab in the Options dialog box (Tools 
-> Options -> Mechanical Design).

Both types of section can be created using the Sketcher. For more information
on sketcher capabilities, see the Sketcher User's Guide. A simple task illustrating
the use of the sketcher is included in this guide; see Sketching.
1. To access user catalog sections, select Other section... in the Section box

list of the Linear Member Definition, Infill Definition or Member on Support
dialog box and proceed as above for standard catalog sections.

Or,

Select the resolved section of interest in the Section box list of the Linear
Member Definition, Infill Definition or Member on Support dialog box.

 

 

 



Creating Linear Members

This task shows how to create linear members.

No sample document is provided.

1. Click the Member  icon.

The Linear Member Definition and Point Definition dialog boxes appear.

Note: Double-click the icon to keep the dialog box and create more than one member.
2. In the Type list, select the type of member you want to create:

Column
Beam
H-Brace
V-Brace.

3. In the Section list, select the shape you want to use. Click:
One of the available section names, or
Other section... to access catalog sections not already listed.

For more information, see Accessing Sections.
4. In the preview or in the Anchor point list, select the desired point at which to anchor the

section along the support axis.
Note: Since the section selected is
symmetrical, gravity anchor points
coincide with standard anchor points.

The illustration to the right shows
standard and gravity anchor points for a
channel shape section.



5. In the Orientation box, use the arrows to change the angular dimension value and orient the
section around its anchor point:

The Orientation field is updated in 90 degree increments by default. Right-click in
this field to change the step.

In the illustrations below, the anchor point is top left.

6. In the Direction list, select how you want to place the member:
Unspecified
Parallel to the XY plane
Parallel to the YZ plane
Parallel to the XZ plane
Parallel to an unspecified plane: click the Direction box and select a plane before
defining the member limits.
On an unspecified plane: click the Direction box and select a plane before defining the
member limits. The member is projected onto the plane.
Parallel to the X axis
Parallel to the Y axis
Parallel to the Z axis
Parallel to an unspecified line: click the Direction box and select a line before defining
the member limits.

7. Define the limits of the member you want to create:

You can define the start and end limits of a member in a variety of different ways, by
Entering coordinates
Selecting wireframe elements
Specifying a length
Specifying an offset to the XY, YZ or XZ plane

Entering Coordinates
Enter point coordinates in the Point Definition dialog box or in the power
input field in the status bar.
You can combine coordinates and selection of wireframe elements when
defining start and end points for members.

Selecting Wireframe Elements
Select a wireframe element in the geometry area.
You can combine coordinates and selection of wireframe elements when
defining start and end points for members.

Wireframe elements are useful construction aids. To create a construction grid, see Creating
a Grid.



Specifying a Length
Enter point coordinates or select a wireframe element to define the start
point.
Click the Length checkbox and enter a value or use the arrows to change
the value in the Length field.
Indicate in the geometry area to identify the direction.

Specifying an Offset to XY, YZ or XZ Plane

Note: This option is only available when the selected direction is parallel to the
XY, YZ or XZ plane. The offset is computed along the normal to the defined
plane.

Click the Offset checkbox and enter a value or use the arrows to change
the value in the Offset field. You can enter a positive or a negative value.
Select wireframe elements or two existing structures.

Specifying an offset is particularly useful when creating members between two existing
structures.
 

A preview of the member guides you as you create. Any changes in the member definition
are immediately reflected in the preview.

 
Parallel to the  z-axis;
moving cursor in
negative direction
Anchor point: Bottom left
Default orientation.

 
Parallel to the z-axis; moving cursor in positive
direction.
Anchor point: Center
Orientation: 90 degrees.

The member is created and has the characteristics defined in the Member Definition dialog
box.

The linear member is added to the specification tree.
To modify a member, right-click it in the specification tree and select the appropriate
command from the contextual menu.
You can translate, rotate and manipulate members.



 

  

 



Creating Infills
This task shows how to create infills between two members or plates.

You can either specify the number of infills you want to place or have the system compute how many to place
based on information you enter about infill spacing.

No sample document is provided.

1. Click the Infill   icon.

The Infill Definition dialog box appears.

2. In the Type list, select the type of infill you want to create:
Column
Beam
H-Brace
V-Brace

3. In the Section list, select the shape you want to use. Click:
One of the available section names, or
Other section... to access catalog sections not already listed.

For more information, see Accessing Sections.
4. In the preview or in the Anchor point list, select the desired point to anchor the section along the support

axis.
Note: Since the section selected is
symmetrical, gravity anchor points coincide
with standard anchor points.

The illustration to the right shows standard and
gravity anchor points for a channel shape
section.

5. In the Orientation box, use the arrows to change the angular dimension value and orient the section around
its anchor point:

The Orientation field is updated in 90 degree increments by default. Right-click in this field to
change the step.

In the illustrations below, the anchor point is top left.



6. Specify the number of infills you want to place:
In the Number box, scroll to a new value with the up and down arrows
Or,
Click the Compute checkbox to have the system compute the number of infills.

 

 

 

 

Use the Compute option to have the system calculate:
The number of equally-spaced infills to place based on the length of reference 1 and a maximum
distance between infills (D2) that you specify. The system adjusts the distance D2.
Note: If you specify the distance to the first infill (D1) and the distance from the last infill (D3) as well,
D3 is re-computed by the system.
Distance D3 from distances D1 and D2 you entered in the Defined mode.

 
7. In the Position box, select

Relative to position infill sections with respect to the plane defined by the selected structures
Or,
Absolute to take infill section orientation into account.

Relative Absolute
8. (Optional) In the Offset box, set an offset with respect to the plane defined by the selected structures.
9. Select the first structure (reference 1).
10. Select the second structure (reference 2).

 
The point at which you select structures is important. The system determines the end nearest this point and
computes infill spacing along the selected structure from this end.
A preview guides you as you create. Any changes in the infill
definition are immediately reflected in the preview.



Options in the Spacing boxes let you define the distances between infills as well as between infills and the
ends of selected structures.

11. Specify infill spacing:

To have infills placed at equal distances along structure 1:
In the Mode box, select Equal.

To specify infill position and spacing with respect to the first structure (reference 1):
In the Mode box, select Defined
In the D1 box, enter a value or use the arrows to change the value to specify the distance from the
end of the structure to the first infill
In the D2 box, enter a value or use the arrows to change the value to specify the distance between
infills
In the D3 box, enter a value or use the arrows to change the value to specify the distance from the
last infill to the other end  of the structure.

Note: In the Defined mode, you must enter distances D1 and D2. Distance D3 is generally deduced by the
system.

To define infill position and spacing with respect to the second structure (reference 2): In the Mode
box, select the appropriate option:

Equal: infills are placed at equal distances along structure 2
Perpendicular to 1: infills are placed perpendicular to structure 1
Perpendicular to 2: infills are placed perpendicular to structure 2
Same as 1: D1 and D3 distances are applied when placing infills along structure 2.

 

 

 

 

 

 

 

 

Use the Same as 1 option when structures are not parallel to keep the same distances between infills and
the ends of structures.



12. When satisfied, click OK to create the infills.

Infills are created and have  the characteristics defined in the
Infill Definition dialog box.

Infills are added to the specification tree.

To modify infills, right-click in the specification tree and select the appropriate command from the
contextual menu.
You can translate, rotate and manipulate infills.

 

  

 



Creating Members on Supports
This task shows how to route straight and curved members along an existing
support. The member can be trimmed to planes, intersection elements or faces
of existing structures selected as limits.

This command is particularly useful when creating curved members.

Open the MemberOnSupport.CATProduct document.

1. Click the Member on Support  icon.

The Member on Support dialog box appears.

2. In the Type list, select the type of member you want to create:
Column
Beam
H-Brace
V-Brace.

3. In the Section list, select the shape you want to use. Click:
One of the available section names, or
Other section... to access catalog sections not already listed.

For more information, see Accessing Sections.
4. In the preview or in the Anchor point list, select the desired point to anchor

the section along the support axis.

file:///E|/WWW/MTNDOCR5/StdEnglish/stdug.doc/src/samples/MemberOnSupport.CATProduct


Note: Since the section selected
is symmetrical, gravity anchor
points coincide with standard
anchor points.

The illustration to the right
shows standard and gravity
anchor points for a channel
shape section.

5. In the Orientation box, use the arrows to change the angular dimension
value and orient the section around its anchor point:

The Orientation field is updated in 90 degree increments by default.
Right-click in this field to change the step.

In the illustrations below, the anchor point is top left.

6. Select the support curve or line:

Select wireframe elements created using the Grid  command or the
CATIA V5 Wireframe and Surface Design product. You cannot select
elements of a sketch.

The member will be routed along the selected support.
A preview guides you as you create. Any changes in member definition are
immediately reflected in the preview.

Arrows identify the direction along which a positive offset is calculated.



Right-click in the geometry area to access the contextual menu allowing you
to specify the number of sections previewed.

7. To orient the section with respect to a reference curve or surface, click the
Reference box and select the desired curve or surface.
Specifying a reference lets you create twisted members.

8. Select the first limit to which you want to trim the member
9. Select the second limit.
10. (Optional) In the Offset box, enter a value or use the arrows to change the

value to offset limit 1 or limit 2 by the specified distance.

Limits can be planes, intersection elements or the faces of existing
structures.



11. Click OK to create the curved member.

The member is created and has the characteristics defined in the Member
on Support dialog box.

The curved member is added to the specification tree.

To modify a member, right-click it in the specification tree and select
the appropriate command from the contextual menu.
You can translate, rotate and manipulate members.

 

  

 



Creating Plates
This task shows how to create different types of plate.

Open the CreatingPlates.CATProduct document.

The sample documents looks like this:

1. Click the Plate   icon.

The Plate Definition dialog box appears.

2. In the Type list, select the desired type of plate.
3. In the Thickness box, use the arrows to change the thickness value or enter a value

directly in the box.
4. Select a support:

The support can be a plane or the face of an existing structure.
5. In the Offset box, use the arrows to change the distance value or enter a value directly in

the box to create the plate parallel to the support, offset by the specified distance.

file:///E|/WWW/MTNDOCR5/StdEnglish/stdug.doc/src/samples/CreatingPlates.CATProduct


6. Define the contour of your plate:
Click the Sketcher icon to open the Sketcher workbench 
Sketch the plate contour in the support plane
Exit the sketcher.

For more information on the Sketcher, see the Sketcher User's Guide.
The plate is created. You can now make any
on-the-fly modifications and see them
reflected in the preview.

Or,
Select points, lines or edges in the
document to define the plate contour.

An arrow normal to the support
and identifying the direction of
extrusion is displayed. As you
select elements, a preview
appears to guide you. Elements
you select are projected onto the
support plane. 
Click Apply or double-click to create the
plate.

7. Select the arrow or click the Reverse direction option in the dialog box to extend the plate
in the opposite direction from that shown.

8. Adjust the plate thickness.
9. Click Apply when satisfied.



You can also modify the shape of your plate and for example create a corner using the
Sketcher.

10. Click OK when done.

The plate is created and has the
characteristics defined in the Plate Definition
dialog box.

The plate is added to the specification tree.

11. Create another structure between the two
plates using a plate face as support.

Your structure now looks like this:



To redefine a plate, right-click it in the specification tree and select Definition from
the contextual menu.
You can translate, rotate and manipulate plates.

 

  

 



Creating End Plates
This task shows how to create a special type of plate called an end plate.

No sample document is provided.

1. Click the End-Plate  icon.

The End Plate Definition dialog
box appears.

2. In the Type list, select the desired type of plate.

3. Define the length, width and thickness of the plate using arrows to change
the values or entering values directly in boxes.

The length and width are defined with
respect to the local axis system of the
structure, for example, in the case of an
I shape, the width is defined along the
x-axis parallel to the flange and the
length along the y-axis parallel to the
web.



4. Select the end of the structure at
which you want to place the end
plate.

The end plate is created as defined
and is added to the specification
tree.

 

5. Click OK when done.

 

 

 



Modifying, Joining & Moving
Modify structures: Right-click the structure in the specification tree and
select the desired type of modification, then make appropriate changes.

  Join structures:   Select the cut in the Joint Definition dialog box, specify an
offset, then select members

 
Translate structures: Select a structure and enter offset values in the Move
dialog box

 
Rotate structures: Select a structure, choose the axis of rotation and enter
an angle in the Move dialog box

 
Manipulate structures: Define the move in the Manipulation Parameters
dialog box, select a structure and drag

 

  

 



Modifying Structures
You can modify the definition (type, section, anchor point and orientation) of both members and
plates. You can also extend, stretch (unconstrained linear members only) and flip members.

All modifications are done via the contextual menu on structures selected in the specification tree.
Note: You cannot select structures you want to modify in the geometry area.

This task shows how to modify members.

No sample document is provided.

1. Right-click the member you want to modify and
select the type of modification you want to make from
the contextual menu.

You can:
Modify the type, section, anchor point and
orientation (Definition).
Add a positive or negative offset at member
ends (Extend).
Stretch unconstrained linear members
(Stretch).
Flip the section (Flip).

Note: Only Definition is available for plates.

If you have created a large number of structures, right-click the structure of interest in the
geometry area then select the Center Graph command to find your structure in the specification
tree.

2. Make the required modification.

Definition: make your selection(s) in the Definition dialog box that appears and click OK
when done.



Extend: the Limits Definition dialog appears. Set new values in offset boxes and/or select
a new limit where appropriate then click OK when done.

For structures created by specifying a length, you can also modify the length value.

Stretch: a graphic manipulator is displayed letting you stretch the unconstrained linear
member along the main axes of the section. Stretch your structure and click OK when
done.

Important: This command is only available for unconstrained linear members, i.e.
those created by entering coordinates or with the Keep link with selected object
option de-activated).

Flip: select this command to flip an asymmetric section.

 



 

 



Joining Structures
This task shows how to specify the type of joint between members and define
how member ends are cut.

No sample document is provided.

 

1. Click the Joint   icon.

The Joint Definition dialog box appears.

2. In the Type list, select the desired
type, for example Normal cut.

Types available are:
None: no cut.
This option lets you remove a previously applied cut.
Weld cut: a cutting plane is used to cut the member you want to
trim.
Miter cut: members are perpendicular with ends cut at an angle.
Normal cut: ends of members are cut perpendicular to the support
axis.

3. In the Offset box, use the arrows to change the offet value or enter a value
directly in the box to offset the member you want to trim from the trimming
member.

4. Select the member serving as limit (trimming member).
5. Select the member you want to trim.

It is important to select members in the correct order.

6. Click Apply to create the cut.

Members are cut back as specified in the dialog box.



 

  

 



Translating Structures
This task will show you two ways to move a structure to a new location:

Entering value(s) in the Move dialog box
Selecting wireframe elements to define the direction.

No sample document is provided.

The structure you want to move must belong to the active object.

1. Click the Translation or Rotation  icon.

The Move dialog box is
displayed.

2. Select the structure you
want to translate.

3. Define the translation:

Entering value(s) in the Move dialog box:

The move is defined in terms of an offset along x, y or z axes.
Enter an offset value for x, y or z in the Offset boxes.



Click Apply.

The selected
structure is
moved
accordingly.

Click Invert to change the direction of the offset and move the
structure in the opposite direction.

The structure is translated in the opposite direction.
You can click Apply as many times as you wish to move the structure to
the desired position.

Selecting wireframe elements:

The move is defined by selecting wireframe elements or selecting a
wireframe element and entering a distance.

Click Selection to define your translation with respect to a wireframe
element.

The Translation tab contents is grayed.

If you select a line or a plane you also need to enter a distance
value. The translation is then done along the selected line or
normal to the selected plane. Selecting two faces or planes
assumes these elements are parallel.



Select two faces
as shown.

Faces are
parallel.

CATIA computes the distance between them. The distance is
displayed in the Offset boxes.
Click Apply to
translate the
structure.

You can
apply this
translation to
other
structures.
Simply select
them and
click Apply.

4. Click OK when done.

 

  

 



Rotating Structures
This task will show you two ways to rotate a structure:

Identify the axis of rotation in the dialog box and enter an angle
Select a wireframe element to define the axis of rotation and enter an
angle.

No sample document is provided.

The structure you want to move must belong to the active object.

1. Click the Translation or Rotation   icon.

The Move dialog box is
displayed.

Translation options are
available. To know how
to translate structures,
see Translating
Structures.

 

2. Click the Rotation tab.
3. Select the structure you

want to rotate.

4. Define the rotation:



Entering a angle and specifying an axis of rotation:
Click one of the Axis options to specify the axis of rotation.
Enter an angle of rotation in the Angle box.
Click Apply.

The selected
structure is
rotated
accordingly.

Selecting wireframe elements:
Click Selection to define your rotation with respect to a wireframe
element.
Select a wireframe
element to define
the axis of
rotation, an edge
for example.

Enter an angle in
the Angle box.
Click Apply to
rotate the
structure.

You can
apply this
rotation to
other
structures.
Simply select
them and
click Apply.

5. Click OK when done.



  

 



Manipulating Structures
The Manipulate command lets you drag to move a structure freehand. It is less constraining than
the Translate and Rotate commands.
This task will show you how to move structures.

No sample document is provided.

The structure you want to move must belong to the active object.

1. Click the Manipulation  icon .

The Manipulation Parameters dialog box appears:

A variety of options let you:
Move selected structures along the x, y or z-axis as well as in
the xy, yz and xz planes
Rotate selected structures around the x, y or z-axis
Select a wireframe element to define the direction of the
move or the axis of rotation.

2. Click the Drag along Y axis icon.
 

3. Select the structure you want to move.

4. Drag to translate the selected structure.

The structure is moved in the specified direction.



5. Select another structure and click Drag around Y axis icon.
6. Drag to rotate the structure.

You are rotating it around the Y axis.

7. Click With respect to constraints.

Note: This option concerns assembly constraints.

If you repeat the previous operation, you will notice that you are not allowed to do so. The
existing parallelism constraint prevents you from moving the selected structure.

8. Click OK when done.

 

 



Creating a Grid
Using grids lets you design in context. You can create structures referencing geometrical grid elements. Design changes
can then be introduced by modifying the grid and updating the structure in consequence.

Note: You can also design in context using assembly constraints.
This task shows how to create a new grid that you can then use as a construction aid to create members.

A grid is made of wireframe elements (lines, points and planes) and is identified in the specification tree. It can be created
using either the Cartesian or Polar coordinate system.

Start the Structure Design workbench (Mechanical Design ->Structure Design from the Start menu).

1. Click the Grid    icon.

The Grid Definition dialog box appears.

2. Enter a name for the grid you want to create in the Name box:

The grid will be identified by this name in the specification tree.
3. Enter absolute coordinates in the Origin box or select a point in the geometry area to define the grid origin.
4. In the First direction in XY plane box:

In the Cartesian tab, enter H and V coordinates to define the local x-axis.
Or,
Click the Polar tab and enter an angle to define the polar axis.
Or,
Select a line in the geometry area.

Note: By default, the local x-axis is positioned along the absolute x-axis.
5. Specify grid coordinates:

In the Cartesian tab, specify the distance between grid points and number of points along x, y and z axes.
Or,
In the Polar tab, specify the radius, amplitude and spacing along the z-axis as well as the number of grid points in
each case.

Note: Clicking More expands the dialog box and lets you enter up to three more different combinations to define your
grid.



6. Click OK to create the grid.

The grid is created and is identified in the specification tree.

Grid planes are associative: planes are offset one from the other. Moving a plane will update the entire grid.

This is useful when modifying a structure: move a plane (double-click to edit) and see the structure defined using the
grid updated when you double-click the root product in the specification tree if the following options were set when you
creating your structure:

Automatic construction constraints option in the Structure Design tab in the Options dialog box (Tools -> Options,
Mechanical Design)
Keep link with selected object and Synchronize all external references for update options in the General tab in
the Options dialog box (Tools -> Options, Mechanical Design).



 

 

 



Advanced Tasks
The advanced tasks you will perform in the Structure Design workbench illustrate
interoperability with other V5 products and how to generate BOMs.

 

Interoperability with V5
Generating BOMs

Working with User Sections

 



Interoperability with V5
 

Sketch profiles for user sections: Sketch your profile in the Sketcher
workbench then save the sketch as a CATPart document in the directory
defined in the Structure Design tab of the Options dialog box
Create cutouts: Edit a plate, then switch to the Part Design workbench.
Sketch the contour of the cutout then create it using the Pocket icon.

Create flanges: Edit a plate, then switch to the Sheet Metal Design
workbench. Use Walls Recognition and Flange Definition icons.

Creating assembly constraints: Switch to the Assembly Design workbench
and place desired constraints on structures.

Generate drawings: Switch to the Generative Drafting workbench and set
drawing options in the New Drawing Creation dialog box.

 

 

 

 



Sketching Profiles for User Sections

This task shows how to sketch profiles for user sections using Sketcher capabilities.

No sample document is provided.

1. Start the Sketcher workbench (Start ->Mechanical Design ->Sketcher). 

2. Select the xy working plane in the geometry area or specification tree.

The Sketcher workbench is displayed.
User sections created using Sketcher capabilities must be created in the xy plane.

3. Sketch your profile, for example use the Circle  icon to sketch a simple circle

that will give a round bar or circular tubing section:
Point where you want to place the center of the circle.
Drag to set the radius.
Click when satisfied.

Note: It is recommended that profile dimensions match actual section dimensions.
4. If desired, set constraints.
5. Exit the sketcher.
6. Using File -> Save, save the sketch as a CATPart document in the directory defined in the Section storage

box of the Structure Design tab in the Options dialog box (Tools -> Options -> Mechanical Design).

Your sketch now appears as a resolved section in the Section list in Linear Member Definition, Infill Definition
and Member on Support dialog boxes. You are now ready to use it to create a structure.

For more information on sketching profiles and setting constraints, see the Sketcher User's Guide.

 



 

 



Creating Cutouts
This task shows how to use Part Design capabilities to create cutouts. Cutouts are
sketch-based features.
It is strongly recommended that you use only standard Part Design commands, such as
Pocket, Hole, Edge Fillet, Chamfer and Split. Using other commands may corrupt your
document.

For more information on Part Design capabilities, see the Part Design User's Guide.

No sample document is provided.

1. Create a simple plate structure in
the Structure Design workbench.

2. Right-click the plate you just
created and select Edit from the
contextual menu.

3. Switch to the Part Design workbench (Start ->Mechanical Design ->Part Design).
4. Select one of the plate faces to define the working plane.
5. Click the Sketcher  icon  to enter the Sketcher workbench.

6. Click the Elongated Hole  icon to sketch your contour.

7. Click where you want to start the
major axis, then drag.

8. Click when satisfied to create the
major axis.

9. Drag and click again to define the
minor axis.

The cutout contour has been
defined.

10. Exit the Sketcher.
11. Click the Pocket  icon in the Part Design workbench.

The Pocket Definition dialog box appears and CATIA previews your cutout.



12. Select Up to last in the Type box to define the limit of your cutout.

CATIA will extend the cutout feature from the sketch plane to the last face
encountered.

13. Click OK to create the cutout.

 

  

 



Creating Flanges

This task shows how to use Sheetmetal Design capabilities to create flanges.

No sample document is provided.

Sheetmetal capabilities are only available for plates.

1. Create a simple plate structure in
the Structure Design workbench.

2. Right-click the plate you just
created and select Edit from the
contextual menu.

3. Switch to the Sheet Metal Design workbench (Start ->Mechanical Design
->Sheet Metal Design).

4. Click the Walls Recognition  icon to have the plate recognized and

access Sheet Metal Design commands.
5. Click the Flange Definition 

icon.

The Flange Definition dialog box
appears.

6. Select the edge on which you want
to create a flange

7. Specify the flange radius, length
and angle. In our example, we
entered 2mm, 50mm and
120degrees respectively.

8. Click OK to create the flange.



All Sheetmetal Design commands are available for plates. For more
information on Sheetmetal Design capabilities, see the Sheetmetal Design
User's Guide.

 

  

 



Creating Assembly Constraints
Creating assembly constraints between structures lets you design in context and, in the case of changes, lets you
control the propagation of modifications. Constraints can be placed as you work.

Note: You can also design in context using a grid.

This task shows how to place an offset constraint between two structures using the Assembly Design workbench.

Open the CreatingAssemblyConstraints.CATProduct document.

1. Select the Assembly Design workbench (Start ->Mechanical Design ->Assembly Design).

2. Click the Offset Constraint  icon

3. Select the inside face of one of the two columns.
4. Select the corresponding face on the other column.

The Constraint Properties dialog box appears.

5. Enter an offset of 1000mm in the dialog box, then click OK.

The two structures are now constrained by an offset distance of 1000mm. If you move one of the structures, the
distance between the structures will remain 1000mm.

file:///E|/WWW/MTNDOCR5/StdEnglish/stdug.doc/src/samples/CreatingAssemblyConstraints.CATProduct


6. Click the Manipulation  icon, then the Drag along Y axis icon in the

dialog box that appears.

7. Select one of the structures and drag to a new position, then click OK in the dialog box.

8. Select the structure you moved, then click the Fix Component  icon to fix it in space.

The entire structure is updated to respect the offset constraint.



For more information on creating constraints, see the Assembly Design User's Guide.

 

  

 



Generating Drawings
This task shows how to generate drawings from your structures using the
Generative Drafting workbench.

No sample document is provided.

1. Create a column or
beam structure in
the Structure Design
workbench.

2. Switch to the Drafting workbench (Start ->Mechanical Design ->Drafting).
The New Drawing
Creation dialog box
appears.

The default drawing
standard, format
and scale is
indicated.

3. Select the drawing
layout you want.

4. Click Modify... to change the scale of the drawing.



5. Change the scale to
0.1 in the New
Drawing dialog box
that appears, then
click OK.

6. Click OK in the New
Drawing Creation
dialog box to create
the drawing.

The Drafting workbench is opened and your drawing displayed.

You can use Generative Drafting and Interactive Drafting to annotate and
dimension your drawings. For more information, see the appropriate User's
Guide.



 

 

 



Generating BOMs
This task shows how to use a sample macro to generate a Bill of Material (BOM) in the form of an Excel
report. You can in this way obtain critical design information.

The sample macro SectionQuantityList.CATScript is delivered in the /installation_folder/code/command
folder. For more information on the installation folder, see the CATIA Infrastructure User's Guide.

No sample document is provided.

1. Before being able to run the macro, you must edit it to identify the folder containing the BOM template
SectionQuantityListTemplate.xls:

Select Tools ->Macro ->Macros...
Set Macro in to External File at the bottom of the Macro dialog box.
Click Select and navigate via Select External File dialog box until you find the sample macro,
then select it and click Open.
Select the macro in the Macro dialog box and click Edit.
Enter the full path of the folder containing the template SectionQuantityListTemplate.xls in the
line starting excelTemplate=
Save the edited macro in the folder identified.

2. Select the structures for which you want to generate the BOM.
Use the Edit ->Search command to assist you identify structures of interest.

3. Start Microsoft Excel.
4. Run the macro:

Select Tools ->Macro ->Macros...
Select the macro in the Macro dialog box and click Run to run the macro.

You can also drag and drop the macro onto your toolbar using Tools ->Customize ->Commands
->Macros. Then simply click the icon to run the macro.
The BOM is generated in the form of an Excel report. Product Structure and Structure Design
attributes are listed.

For more information on recording, running and editing macros, see the CATIA Infrastructure User's
Guide.

 

  

 



Working with User Sections
 

Sketch profiles for user sections: Sketch your profile in the Sketcher
workbench then save the sketch as a CATPart document in the directory
defined in the Structure Design tab of the Options dialog box
Define anchor points for user sections: Edit the sketch, create a construction
point renaming it with the prefix catStr. Exit the sketcher then save the
document.
Create & complete parametric section catalogs: Make your file tree, create
design tables and CSV files then run your macro to generate the catalog.

 

 

 

 



Sketching Profiles for User Sections

This task shows how to sketch profiles for user sections using Sketcher capabilities.

No sample document is provided.

1. Start the Sketcher workbench (Start ->Mechanical Design ->Sketcher). 

2. Select the xy working plane in the geometry area or specification tree.

The Sketcher workbench is displayed.
User sections created using Sketcher capabilities must be created in the xy plane.

3. Sketch your profile, for example use the Circle  icon to sketch a simple circle

that will give a round bar or circular tubing section:
Point where you want to place the center of the circle.
Drag to set the radius.
Click when satisfied.

Note: It is recommended that profile dimensions match actual section dimensions.
4. If desired, set constraints.
5. Exit the sketcher.
6. Using File -> Save, save the sketch as a CATPart document in the directory defined in the Section storage

box of the Structure Design tab in the Options dialog box (Tools -> Options -> Mechanical Design).

Your sketch now appears as a resolved section in the Section list in Linear Member Definition, Infill Definition
and Member on Support dialog boxes. You are now ready to use it to create a structure.

For more information on sketching profiles and setting constraints, see the Sketcher User's Guide.

 



 

 



Defining Anchor Points for User
Sections

Anchor points can be defined on user-defined parametric sections.

Note: All resolved sections automatically inherit the defined anchor point.

This task shows how to define an anchor point.

No sample document is provided.

1. Edit the sketched section.

2. If the anchor point you want to define does not correspond to an
existing point of the sketch, create an appropriate construction point.

3. Rename the point:
Right-click the point and select Properties
from the contextual menu.
Select the Feature Properties tab in the
Properties dialog box.
Rename the point using the prefix catStr,
for example catStrUserAnchorPoint.

4. Exit the sketcher,  then save the sketch as a CATPart document (File
->Save).

5. Return to the Structure Design workbench:

The new anchor point is automatically displayed.

 

  

 



Creating & Completing Parametric
Section Catalogs

You can create new catalogs or add sections to existing catalogs.
Section catalogs are located in the directory
installation_folder/startup/components/StructuralCatalogs.
Sketches of parametric sections (I, U, L, T, double U, double L, bulb and tube
shapes) are stored in the sub-directory Sketchs.

This task shows how to create a user catalog for parametric sections.

No sample document is provided.

1. Make a USER directory containing CsvFiles, DesignTables and VBScript
sub-directories.

2. Create the design tables corresponding to the various catalog families.
Do not link them to parametric sketches.

3. Create CSV-type files.
The name of the design table must be the last parameter in the first line
starting ENDCHAPTER.

For example, ENDCHAPTER: Name;Icon;DesignTable;
The full path name of documents must be given.

Typical CSV file:
ENDCHAPTER;HEA;I_SectionStructureI;OTUA_HEA;

Keywords;Section;

Types;String;

;HEA100;e:\users\jcm\StructuralCatalogs\Sketchs\IShape.CATPart

;HEA120;e:\users\jcm\StructuralCatalogs\Sketchs\IShape.CATPart

;HEA140;e:\users\jcm\StructuralCatalogs\Sketchs\IShape.CATPart

4. Using the example OTUA/VBScript to help you, create and run a macro that will
generate the catalog.
If needed, use the OTUA catalog as an example when creating your user
catalog.

This task shows how to add sections to existing catalogs.



To add sections to existing catalogs, you must rename the path of linked documents in
CSV files because these files contain the full path name. To do so, one Excel file per
sample catalog containing an appropriate macro is provided. For example, the Excel
file for the OTUA catalog is OTUA_hierarchy.xls. Excel files are located in the CsvFiles
directory.
1 Edit the Commands sheet of the appropriate Excel file, entering the necessary

information.

Note: The first sheet named Data contains all CSV files in the catalog.
2. Click Modify absolute path of pointed CATPart in CSV files to rename the path.
3. Add new sections.
4. Generate the catalog as above.

 

 

 



Workbench Description
The CATIA Structure Design Version 5 application window looks like this.

Click the hotspots to see related documentation.

 

Design Toolbar
Assembly Toolbar
Specification Tree



Design Toolbar

 

See Creating a Grid

See Creating Linear Members
See Creating Infills

See Creating Members on Supports

See Creating Plates

See Creating End Plates

See Joining Structures

 

 



Assembly Toolbar

 

See Translating Structures and Rotating Structures

See Manipulating Structures

  

 



Specification Tree

Icons displayed in the specification tree and specific to the Structure Design
workbench are as follows:

A flat structure.

A linear or curved structure.

Support axis along which the section is anchored.



 

 



Customizing
 

Structure Design Settings: Before you start you first working session, you
can customize the way you work to suit your habits.

file:///E|/WWW/MTNDOCR5/BasEnglish/basug.doc/src/basugcustd01.htm


Structure Design Settings
This first task shows you how to customize Structure Design settings.

1.
Select Tools -> Options... from the menu bar.

The Options dialog box appears.
2. Click Mechanical Design -> Structure Design in the left-hand box.
3. Click the Structure Design tab.

The Structure Design tab lets you customize:
Member and plate default colors and materials: 

Member color: select the default color for members in
the box list.
Plate color: select the default color for plates in the box
list.
Member material: select the default material for
members in the box list.
Plate material: select the default material for plates in
the box list.



Manage user types:
Add: enter the name of the member or plate type then
click Add to add user types.
Remove: select the member or plate type in the list then
click Remove to remove user types.

Paths to directories containing sample standard catalog sections
and available sections:

Catalog storage / Directory: identifies the path of the
directory containing sample standard catalog sections:

downloaddirectory/OS/startup/components/structuralcatalogs

where OS is the operating system, for example
intel_a (Windows NT).
Section storage / Directory: identifies the full path of
the directory containing available sections, for example
e:\tmp.

This directory contains resolved user-defined
sections stored here directly and any sample
standard or user-defined catalog sections
accessed via the Other section... option. It is
recommended that an empty directory be
identified.

4. Click OK in the dialog box when done.
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Glossary 
A

assembly constraint A geometric or dimension relation between two components in an assembly, for example a
surface contact or parallelism constraint

C

constraint
In the Structure Design workshop, there are two types of constaint:

Construction constraint
Assembly constraint

construction constraint A relation between the structure you create and the underlying wireframe geometry used as
construction geometry

curved member A structure having initial curvature

I
infill One or more linear members created in one go between two structures.

J

joint

The way members are fastened together. Several cuts are proposed:
Weld cut: a cutting plane is used to cut the member you want to trim
Miter cut: members are perpendicular with ends cut at an angle
Normal cut: ends of members are cut perpendicular to the support axis

L
linear member A straight structure, for example a column or beam

M
member A linear or curved structure

P
plate A flat structure

S
section Profile defining the shape of a member
support axis The line in a member along which the selected section is anchored

W
wireframe element Elements such as points, lines or curves used as construction aids to help you create your

structures
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