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Preface
DMU Kinematics Simulator is an independent CAD product dedicated to simulating assembly
motions. It addresses the design review environment of digital mock-ups (DMU) and can
handle a wide range of products from consumer goods to very large automotive or aerospace
projects as well as plants, ships and heavy machinery.

DMU Kinematics Simulator is a dedicated DMU Navigator workbench and is available on both
UNIX and Windows NT environments.

This guide is organized as follows:
Getting Started

Provides a scenario allowing you to get acquainted with the product.
Basic Tasks

Provides a step-by-step guide for using DMU Kinematics Simulator. Useful tips are given for
getting the most out of the product.

Advanced Tasks

Provides a step-by-step guide for using DMU Kinematics Simulator along with complementary
DMU Navigator products.

Workbench Description

Describes menu commands and workbench toolbars that are useful for DMU Kinematics
Simulator.

Glossary

Provides definitions of terms that are specific to DMU Kinematics Simulator.

DMU Kinematics Simulator Version 5 makes use of CATIA Version 4 multi-model sessions that
have been prepared with one or more kinematic mechanisms. This preparation task is
described in the Basic User Tasks section of this guide.

Using This Guide
More Information



Using This Guide
This guide is intended for the user who needs to quickly become familiar with DMU Kinematics
Simulator. The user should be familiar with basic DMU Navigator Version 5 concepts such as
document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-step
tutorials "Getting Started". You will use the samples contained in C:\Program Files\Dassault
Systemes\B05doc\online\kinug\samples folder.

The next sections present main capabilities in the form of user's tasks. It may be a good idea to
take a look at the section describing the menus and toolbars.

 



Where to Find More Information

Prior to reading this book, we recommend that you read the
DMU Navigator User's Guide
Infrastructure User's Guide
Knowledge Advisor User's Guide

You may also like to read the following complementary DMU Navigator product guides, for
which the appropriate license is required:

DMU Fitting Simulator User's Guide
DMU Space Analysis User's Guide
Conventions

 

 



Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you
recognize and understand important concepts and specifications. The following text
conventions may be used:
       The titles of CATIA, ENOVIA & DELMIA documents appear in this manner throughout the
text.
       File -> New identifies the commands to be used.

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button, whenever you read

Select (menus, commands, geometry in graphics area, ...)
Click (icons, dialog box buttons, tabs...)
Double-click
Shift-click
Ctrl-click
Check (check boxes)
Drag
Drag and drop (icons onto objects, objects onto objects)

Drag
Move

Right-click (to select contextual menu)

Graphic conventions are denoted as follows:

indicates the estimated time to accomplish a task.

indicates a target of a task.

indicates the prerequisites.

indicates the scenario of a task.

indicates tips



indicates a warning.

indicates information.

indicates the end of a task.

indicates functionalities that are new or enhanced with this Release.
Enhancements can also be identified by a blue-colored background in the left-hand
margin.

 



What's New?
 BASIC TASKS 

Designing a V5 Mechanism:

Enhanced: About Joints

Creating Joints With Assembly Constraints

Enhanced: Creating Revolute Joints
New: Creating Prismatic joints
New: Creating Cylindrical Joints
New: Creating Spherical Joints
New: Creating Planar Joints
New: Creating Rigid Joints

Creating Joints Without Assembly Constraints
curved-based joints: run a maximum area (auto search of prolongation)

Continuity in Tangency for:
 
Enhanced: Creating Point Curve Joints
Enhanced: Creating Point Surface Joints
Enhanced: Creating Roll Curve Joints
Enhanced: Creating Slide Curve Joints
New: Creating Universal Joints

Running Simulations

Commands:
Command range now stored in the model and no longer in the settings

New: Defining Laws in a V5 Mechanism (possibility to define the command value relationship
to time using Knowledgeware capabilities
Enhanced: Simulating With Commands  

 ADVANCED TASKS 

New: Creating Revolute Joints with Offset (Advanced mode)
New: Creating Revolute Joints With Centered Option
New: Using the Trace Command

Enhanced: Defining a Swept Volume, you can now to interrupt the computation and to save



the result in wrl format)

WORKBENCH DESCRIPTION

Enhanced: DMU Kinematics Toolbar
Enhanced: DMU Kinematic Joints Toolbar
Enhanced: DMU Generic Animation Toolbar



Getting Started
Before getting into the detailed instructions for using DMU Kinematics Simulator Version 5, the
following tutorials aim at giving you a feel of what you can do with the product. It provides a
step-by-step scenario showing you how to use key functionalities.
The main tasks described in this section are:

Designing a V5 Mechanism
Using V4 Kinematic Data

 



Designing a V5 Mechanism
Before getting into the detailed instructions for using DMU Kinematics Simulator Version 5, the
following tutorial aims at giving you a feel of what you can do with the product. It provides a
step-by-step scenario showing you how to use key functionalities.
The main tasks described in this section are:

 

Entering The Workbench
Creating Mechanism & Joints

Creating Cylindrical Joints
Defining a Command
Defining a Fixed Part

Simulating a V5 Mechanism

 
These tasks should take about 20 minutes to complete.

 



Entering the Workbench
Before starting this scenario, you should be familiar with the basic commands common to all workbenches.
These are described in the DMU Navigator User's Guide.
This first task will show you how to enter the DMU Kinematics Simulator workbench and select your models.

1. Select Digital Mockup -> DMU Kinematics from the Start menu.
The DMU Kinematics workbench is loaded and an empty document opens:

2. Select File -> Open from the menu bar.
3. Select the rods.CATProduct  document from the samples folder.

Click Open to open the selected file.
The specification tree is displayed showing all the selected products.



4. Select the products in the tree, then select Edit->Representations->Design Mode. You can now expand the tree
to show all the design components of the products.

Use the Fit All In icon  to position the model geometry on the screen.

 

 



Creating a Mechanism and Revolute Joints
This task will show you how to create a mechanism and revolute joints.

Open the rods.CATProduct document.

1. Select the product in the specification tree, then select Edit->Representations->Design Mode.
You can now expand the tree to show all the design components of the products.

2.
Click the Revolute icon  from the DMU Simulation toolbar.
The Joint creation : Revolute dialog box is displayed:
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3. Click New Mechanism.

The Mechanism is identified in the specification tree.

Now you need to select two lines and two planes.
4. Select Line 1 in the geometry area. In our example select a cylinder as shown below.

The dialog box is automatically updated with your selection.

5.
Select Line 2 in the geometry area. Select a second cylinder.
The dialog box current selection field is automatically updated.



6. Select the planes as shown below.
The Current selection field is automatically updated.

7. Click Ok to end the Revolute Joint creation.
The Revolute Joint is created.
The specification tree is updated.

Proceed in the same manner to create joint 2, joint 3.

This is what you obtain:



You can also create a new mechanism selecting Insert-> New Mechanism... from the Menu bar.
The new mechanism is created and identified in the specification tree.

 

  



Creating Cylindrical Joints
This task will show you how to create cylindrical joints.

You created a mechanism and 3 revolute joints as shown in the previous task.

1.
Click the Cylindrical icon  .
The Joint Creation: Cylindrical dialog box appears:



2. Select Line 1 in the geometry area. In our example
select a cylinder as shown opposite:

The dialog box is automatically updated with your
selection.

3. Select Line 2 in the geometry area. In our example
select a cylinder as shown opposite:

The dialog box is automatically updated with your
selection.



4. Click OK to end the cylindrical joint creation.

The Cylindrical Joint is created as well as the constraints.
The specification tree is updated.

You can define commands while creating cylindrical joints:
Driven angle
Driven length

all you need to do is to check the required option.
Remember that you can at any time modify the command. For this, double-click the joint in the specification tree
and edit the settings in the displayed dialog box. For more details, please refer to Editing joints.

 



  



Defining a Command
You can either define a command after joint creation or during joint creation.

This task will show you how to define a Command after joint creation.

1. Double-click joint 3 in the specification tree.

The Joint Edition dialog box is displayed.

2. Activate the Driven angle option. The command will be an angle type command.
3. Click Ok to confirm your operation.

The command is identified in the specification tree.



 

  



Defining a Fixed Part
This task will show you how to define a Fixed part.

1.
Click the Fixed Part icon  from the DMU Kinematics toolbar or select
Insert->Fixed Part... from the menu bar.
The New Fixed Part dialog box is displayed.

2. Select the Fixed Part either in the geometry area or in the specification tree.

3. The fixed Part is automatically defined.



The fixed part is identified in the
specification tree.

At any time you can use the undo command  to modify your selection.

 

  



Simulating a V5 Mechanism
This task will show you how to simulate the V5 mechanism you created.

You designed a V5 mechanism as described in the previous steps.

1.
Click the Simulation With Commands icon .
The Kinematic Simulation dialog box is displayed:
 
The command of the kinematics mechanism are
available as shown opposite.

 

2. a.Manipulate the slider of the command.
The  kinematics mechanism moves accordingly.

2. b. Use the manipulator in the geometry area. For this:
Move the mouse over a joint. The driven joint highlights and the manipulator appears.
Drag the model with the left mouse button.



For more information please refer to Running Simulations and About Joints.

You can also enter a value for the command  to achieve the same result.  

Note that if you click the  button, the Kinematics Simulation dialog box expands. The immediate option
is set by default. For more information about the On request option, please refer to  Simulating on Request

 

 



Using V4 Kinematic Data
 

Entering the Workbench
Browsing the Mechanism

Simulating With Commands
Simulating With Laws

 
These tasks should take about 20 minutes to complete.

 

 



Entering The Workbench
Before starting this scenario, you should be familiar with the basic commands common to all workbenches.
These are described in the DMU Navigator User's Guide.
This first task will show you how to enter the DMU Kinematics Simulator workbench and select your models.

1. Select Digital Mockup->DMU Kinematics from the Start menu.
The DMU Kinematics workbench is loaded and an empty document opens:

2. Select Insert -> Existing Component... from the menu bar.
3. Select the desired Kinematics model files by clicking the first one then shift-clicking the last one you want.

Click Open to open the selected files.
The specification tree is displayed showing all the selected products.



4. Select the products in the tree containing kinematics objects, then select Edit ->Representations->Design Mode.
You can now expand the tree to show all the design components of the products.

Remember that DMU Kinematics Simulator exploits CATIA Version 4 multi-model sessions that have been
prepared with one or more kinematic mechanisms.

Use the Fit All In icon  to position the model geometry on the screen.

 

 



Browsing the Properties of the
Kinematics Mechanism

This task will show you how to browse the properties of the selected kinematics
mechanism.

Insert  the KIN_EX17* .model files from the samples folder.

If you work with the Cache System, please make sure you are in Design mode (select
Edit->Representations->Design Mode.). for more detailed information, please refer to
the DMU Navigator user's Guide - Task: Viewing the Cache Content.

1. Select KIN_EX17_00_F1_ACTIVE and expand the tree.

2. Right-click the
kinematics mechanism
in the specification tree
or select the
Edit->Properties... from
the menu bar.



3.  In the first case, select
Properties from the
contextual menu
displayed.

The Properties dialog box is displayed:



4. Click OK.
5.

Click the Mechanism Analysis icon  .
The General Properties of the kinematics mechanism are displayed as shown.

6. You can select another mechanism using the Mechanism name combo.

7. If you check the Show
joints, this is what you
obtain:

8. If you click the  button, you access to a graphic representation of the laws
associated to each command. It is represented by a colored curve. When you pass the
cursor along the curve, information about the law is displayed in the status bar.



9. The  button is described in detail in Analyzing A Mechanism.

For more detailed information about laws, please refer to Simulating With Laws.

  



Simulating With Commands
This task will show you how to run a kinematics simulation with commands.

Insert the KIN_EX17* .model files from the samples folder.

If you work with the Cache System, please make sure you are in Design mode (select
Edit->Representations->Design Mode.). for more detailed information, please refer to
the DMU Navigator user's Guide - Task: Viewing the Cache Content.

. In our sample document, there is only one mechanism. If you work with a product
containing more than one mechanism, it is strongly recommended to select the
mechanism you need before starting the simulation with commands.

1. Click the Simulation With

Commands icon .

The Kinematic Simulation dialog
box is displayed:

The commands of the
kinematics mechanism are
available as shown opposite.

2. Manipulate the slider of a command. For instance select the LEFT.
The corresponding part of the kinematics mechanism moves accordingly.

Note that if you click the  button, the Kinematic Simulation dialog box expands.
The immediate option is set by default. For more information about the On request
option, please refer to  Simulating on Request.



You can use the slider, enter a value or manipulate the geometry directly to achieve the
same result.

3. Manipulate the other commands in the same way.

 

  



Running a Simulation With Laws
This task will show you how to run a kinematics simulation with laws that are already defined on the
mechanism.
Insert the KIN_EX17* .model files from the samples folder.
The Kinematics Simulation dialog box is displayed as described in the previous task.
If you work with the Cache System, please make sure you are in Design mode (select
Edit->Representations->Design Mode.). for more detailed information, please refer to the DMU Navigator
user's Guide - Task: Viewing the Cache Content.

1.
Click the Simulation With Laws icon .
The Kinematic Simulation dialog box appears.

2. Set the Number of steps to 10, then click the Play VCR button.
The mechanism moves according to the pre-defined laws.
Notice that you cannot record simulations within the Simulation With Laws functionality. If you need to
record such a simulation or several simulations, please refer to Recording Positions.
You can use the other VCR buttons to run the simulation again in different modes (backward, step by step,
and so on).

 

 



Basic Tasks
The table below lists the tasks you will find in this section.

 

Setting Up Your Session
Designing a V5 Mechanism

Designing Joints With Assembly Constraints
Desiging Joints Without Assembly Constraints

Running Simulations
Reviewing Simulations

Managing Dressup Mechanism

 



Setting Up Your DMU Kinematics
Simulator Session

DMU Kinematics Simulator provides easy methods to simulate mechanisms previously defined
using the CATIA Version 4 KINEMAT and KINEMUSE functions.

You may find it useful to refer to your CATIA Version 4 Kinematics User's Reference Manual.

 
Prepare CATIA Version 4: transfer the solid and surface geometry that represents the moving
parts into separate models (1 part per model). The model containing the kinematics mechanism
should only be a stick model (that is, wireframe plus the definition of the mechanism). Use
KINEMUSE function's DRESSUP item to define set/model relationships. Save all models and, if
needed, the session.
Convert V4 Kinematic Data into DMU Kinematic V5: open the model containing the kinematics
mechanism. In the specification tree where the Version 4 kinematics model is displayed, select
the mechanism you wish to copy into the Kinematics Simulator Version 5. Put the data you
have selected in the clipboard, then select Application in the specification tree and paste.
Open Version 5: enter the DMU Kinematics workbench, then select Insert->Existing
Component in order to select the desired models.

 

 



Preparing a Multi-Model Session in
CATIA Version 4

This task shows how to prepare a CATIA Version 4 kinematics mechanism for use
in DMU Kinematics Simulator Version 5.

1. Transfer the solid and surface geometry that represents the moving parts into
separate models (1 part per model).
The model containing the kinematics mechanism should only be a stick model (that
is, wireframe plus the definition of the mechanism).

2. Use KINEMUSE function's DRESSUP item to define set/model relationships.
3. Save all models and, if needed, the session.

 

 



Converting Version 4 Kinematics Data
into Kinematics Version 5 Data

This task shows how to convert  CATIA Version 4 kinematics data into  DMU
Kinematics Simulator Version 5.Data

Insert  the KIN_EX17* .model files from samples folder.

If you work with the Cache System, please make sure you are in Design mode (select
Edit->Representations->Design Mode.). for more detailed information, please refer to
the DMU Navigator user's Guide - Task: Viewing the Cache Content.
The following task shows how kinematics data is pasted from an existing Version 4
model to an existing Version 5 document alongside V5  data. You can of course also
insert the V4 data into a new Version 5 document.

1. Open the model containing the kinematics mechanism.

Open the Kinematics Simulator workbench if necessary.

The model containing the kinematics mechanism should only be a stick model 
(that is, wireframe plus the definition of the mechanism).

2. In the specification tree or in the geometry area where the Version 4 kinematics model
is displayed, select the mechanism you wish to copy into the Kinematics Simulator
Version 5. In our example, select KIN_EX_00_F1_ACTIVE and LANDING GEAR.





3. You can also use the drag &drop capability.
4. Put the data you have selected in the clipboard. To do this, either click the Copy icon,

select the Edit->Copy command or select the Copy command in the contextual menu.

5. Select Application in the specification tree.



6. Now either click the Paste icon, select the Edit->Paste command or select the Paste
command in the contextual menu.
This operation recovers the data previously put in the clipboard. 

.
You may want to click the Fit All In icon    to fit all data in the window.

The dress up is maintained when you perform a copy/paste within the same
document as it is the case below:

Notice that the toolbars change depending on whether a Version 4 model or a DMU
Kinematic Version 5 document is selected.

The result should look something like this:



In some cases, the conversion is impossible (i.e isolated solids), in this case  .cgr files are
automatically created for these solids. If you need to visualize them, select
Insert->Existing Component from the menu bar.

 

What About the Elements You Convert?
To make sure the elements you need to handle in your session are those you expected, here
is a list presenting the CATIA  V4 Kinematics data supported when converted  into a
Kinematics Version 5 document:

V4 Data Type V5 Element Type

model product

set sub-product + associated part



  Geometry contained in the set

V4 mechanism V5 mechanism

V4 joint V5 joint

V4 Command V5 Command

V4 Fix V5 Fix

 

  



Opening Your DMU Kinematics Simulator
Document in Version 5

This task recalls how to open a DMU Kinematics Simulator Version 5 document.

1. Enter the DMU Kinematics workbench, then select Insert->Existing Component in
order to select the desired models.

Please refer to Entering the DMU Kinematics Workbench and Selecting Models
2. Activate the desired kinematics products in the specification tree.

 

 



Designing a V5 Mechanism
 

About Joints: gives background information about joints

Creating Joints: select the to be created joint from the Kinematic Joints toolbar. select the
required parameters within the dialog box and click ok.

Create Mechanism and Revolute Joints: select Insert->New Mechanism... from the menu bar or
click the Revolute Joint icon, then click New Mechanism in the dialog box displayed. Select two
lines and two planes and click Ok.

Define a Fixed Part: click the Fixed Part icon or select Insert->Fixed Part... from the menu bar.
select the part in the specification tree or in the geometry area and click Ok.
Define Commands: check the option the required option within the joint creation dialog box.
Please refer to About Joints to obtain the list of joints which can be assigned a command.
Edit Joints: double-click the joint to be edited in the specification tree. rename the joint, add a
command if necessary.
Convert Constraint to a mechanism: click the Assembly Constraints conversion icon. Click New
Mechanism , then click the Auto create button or click the more button to convert constraints
manually. When done, click Ok

 
Using the Update Command: move the parts, click the Update positions icon .The Update
Mechanism dialog box is displayed: The "Take current positions for rigid joints' option lets you
take into account the new position.Click Ok

 

  



About Joints
DMU Kinematics Simulator lets you define and edit 11 different joint types.

The table below describes the joint types and their characteristics:

GRAPHIC
REPRESENTATION JOINT TYPE DEGREES OF

FREEDOM COMMAND TYPE DIRECT
MANIPULATION

Revolute 1 Rotation Angle YES / Left-mouse button

Prismatic 1 Translation Length YES / Left-mouse button

Cylindrical

   

1 Rotation
1 Translation

 

 

Length + Angle Length:
Left-mouse

button

Angle:
Left-Mouse

button +
Middle-Mouse

button
AND/OR

Angle or Length YES / 
Left-mouse 

button

 
Spherical 3 Rotations _           NO

Planar 2 Translations
1 Rotation _ NO

Rigid _ _ NO

Roll Curve 1 Rotation
1Translation Length NO

Slide Curve 2 Rotations
1 Translation _ NO

Point Curve 3 Rotations
1 Translation Length NO

Point Surface  2 Translations
3 Rotations _ NO

Universal Joint 1 Rotation _ NO

Only the joints which are assigned a command can be manipulated.

 

 



Creating a Mechanism 
and Revolute Joints

This task shows how to create a kinematics mechanism to use in DMU Kinematics
Simulator Version 5.

Open the rods.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Revolute icon  from the DMU Simulation Toolbar.
The Joint Creation: Revolute dialog box is displayed:

3. Click New Mechanism.
The Mechanism is identified in the specification tree.
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Now you need to select two lines and two planes

4. Select Line 1 in the geometry area. In our example select a cylinder as shown
opposite:
The dialog box is automatically updated with your selection.

5. Select Line 2 in the geometry area. Select a second cylinder.
The dialog box current selection field is automatically updated.



6.  Select the planes as shown below.
The Current selection field is automatically updated.
The Revolute Joint is created.
The specification tree is updated.

7. Click Ok to end the Revolute Joint creation.



8.  Proceed in the same manner to create other joints.

Do not forget to define a command and at least one fixed part within your mechanism.

You can also create a new mechanism selecting Insert-> New Mechanism... from the
Menu bar.

 

  



Creating Joints
This task shows how to create joints in a V5 mechanism.
You can now create11 joint types from the following list

Revolute 

Prismatic 

Cylindrical 

Spherical 

Planar 

Rigid 

Roll Curve 

Slide Curve 

Point Curve 

Point Surface 

Universal 

Open the rods+3joints.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box. Remember though, that you
create a mechanism independently from the joints by selecting Insert->New Mechanism... from the menu bar.

1. Click the Revolute Joint icon from the DMU Kinematics
toolbar (Revolute joint is the default joint type)

2. Click the arrow within the icon and undock the 
Kinematic Joints  toolbar.

The DMU Kinematics toolbar is displayed:
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3. Select the joint type of your choice.

4.
For instance click the rigid joint icon .

The Joint Creation: Rigid dialog box is displayed.

The term Rigid corresponds to "Fully restricted" in the standard Kinematic terminology.

5. Select the parts either in the geometry area or in the specification tree.



6. Click Ok to confirm your operation.

The Rigid Joint is identified in the specification tree.

For more information, please refer to About Joints and Creating Mechanisms and Joints.

 

  



Defining a Fixed Part
This task will show you how to define a Fixed part.

Open the rods+4joints+cmd.CATProduct document.

1.
Click the Fixed Part icon  from the Simulation toolbar or select Insert->Fixed
Part... from the menu bar.
The New Fixed Part dialog box is displayed.

2. Select the Fixed Part either in the geometry area or in the specification tree.

3. The fixed Part is automatically defined.
The Fixed part is identified in the specification tree.
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At any time you can use the undo command  to modify your selection.

 

  



Defining Commands
You can define a command either during joint creation or after joint creation.

This task shows how to define a command on a cylindrical joint during its creation. 

Open the rods+4joints.CATProduct document. You created a mechanism.

1. Double-click Joint 4 in the specification tree

The joint Edition dialog box is displayed
2. Check the Driven angle option, for instance.

3. Click Ok to confirm your operation.
The command is identified in the specification tree.

You can also create the command while creating a joint.
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Editing Joints
DMU Kinematics Simulator lets you easily edit joints. Editing joints means you can modify:

its name
deactivate the command

This task shows you how to do so.

Open the  rods+4joints.CATProduct  document. 

1. Double-click the joint to be edited in the specification
tree. For instance Joint 1.
The Joint Edition dialog box displays:

2. In the name field enter a meaningful name: Revolute
1-3 for instance.

3. Check the Driven angle command.

4. Click OK to confirm your operation.
The Joint is updated and identified in the specification
under its new name.
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Note that you can edit the mechanism name. For this all you need to do is double-click the mechanism in the
specification tree and enter a new name in the dialog box displayed and click OK.

 

  



Converting Constraints into Joints 
(Beginner's Mode)

This task show you how to convert Assembly constraints into V5 joints.

Open the jigsaw_with_constraints.CATProduct document. The constraints are visible
both in the geometry area and in the specification tree

If you work with the Cache System, please make sure you are in Design mode (select
Edit->Representations->Design Mode.). for more detailed information, please refer to
the DMU Navigator user's Guide - Task: Viewing the Cache Content.

1. Make sure you are in Design Mode (Edit->Representations->Design Mode).

2.
Click the Assembly Constraints conversion icon  from the DMU Kinematics
toolbar.
The Assembly Constraints Conversion dialog box appears:
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3. Click on the New mechanism button.

4. Click on the Auto Create button to launch the operation.
You can see that there are 5 unresolved pairs of products

. The constraints are converted into V5 joints. The 5 joints are identified in the
specification tree and highlighted in the geometry area



You need to create the command manually or click the  button and refer to
Converting Constraints into Joints (Advanced Mode)

5.
Click Ok to confirm your operation.

Now, let's create the command
6. Double-click Joint.4 (Revolute) in the specification tree.

The Edit Joint Edition dialog box is displayed

7.
Check the Driven angle option and then OK to create the command.

The command is created and identified in the specification tree



An information message is
displayed, your mechanism can now
be simulated.

8.
Click OK.

 

  



Using the Update Command
This task show you how to use the update command  a very powerful tool which lets you keep
the Assembly workbench and the Kinematics Simulator workbench synchronized. It means the
modifications done are taken into account and the joints or constraints are respectively updated.

What is taken into account ?
moving parts in the geometry area 
deleting or modifying assembly constraints

 

Open the rods_with_joints.CATProduct  document.

1. Move the Rod.2. and Rod.1 for this:
 Point to the compass manipulation handle
 Drag and drop the compass onto the rod.4 in the geometry area
 Move the rod.2.

2. Reposition the 3D compass as it was.

3.
Click the Update positions icon .
The Update Mechanism dialog box is displayed:
The Take current positions for rigid joints option lets you take into account the new position.
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4. Click Ok to confirm your operation.
The mechanism is updated and the part is back to its initial position.

.

Now, move Rod.2 and Rod.1 in the same way .

5.
Click the Update positions icon .

6. Check the Take current positions for rigid joints option.

. This is what you obtain:



Now simulate the mechanism. Please refer to Simulating With Commands.

The current position has been kept for Joint.2 (Rigid, Rod.4, Rod.1)

Now delete an assembly constraint.  

7. If you need information about this particular constraint: double-click Coincidence.2 (Rod.3, Rod.4) in
the specification tree to display the Constraint Definition dialog box.

8.
Right-click Coincidence.2 (Rod.3, Rod.4) in the specification tree. 

9.
Select Delete form the contextual menu displayed.



10.
Click the Update positions icon .
The Update Mechanism dialog box appears.

11. Click OK.

The joints within the mechanism are updated
Joint.1 (Revolute, Rod.3, Rod.4) is converted into a Cylindrical joint as shown below:

 



 



Designing Joints With Assembly Constraints
 

Create Revolute Joints: click the Revolute Joint icon from the Kinematic Joints toolbar, then select the
required parameters in the dialog box displayed, when done click Ok.

Create Prismatic Joints: click the Prismatic Joint icon from the Kinematic Joints toolbarthen select the required
parameters in the dialog box displayed, when done click Ok.

Create Cylindrical Joints: click the Cylindrical Joint icon from the Kinematic Joints toolbar, then select the
required parameters in the dialog box displayed, when done click Ok.

Create Spherical Joints: click the Spherical Joint icon from the Kinematic Joints toolbar, then select the
required parameters in the dialog box displayed, when done click Ok.

Create Planar Joints: click the Planar Joint icon from the Kinematic Joints toolbar, then select the required
parameters in the dialog box displayed, when done click Ok.

Create Rigid Joints: click the Rigid Joint icon from the Kinematic Joints toolbar, then select the required
parameters in the dialog box displayed, when done click Ok.

 

  



Creating Revolute Joints
(Beginner's Mode)

This task shows how to create revolute joints in a V5 mechanism.

Open the Create_Revolute.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Revolute Joint icon  from the DMU Simulation Toolbar.
The Joint Creation: Revolute dialog box is displayed:

3. Click New Mechanism.
The Mechanism is identified in the specification tree.

4. The Null Offset option is set by default (radio button). keep it as it is.

Now you need to select two lines and two planes

5. Select Line 1 in the geometry area. In our example select the hinge axis as shown below:
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6. Select Line 2 in the geometry area. Select the wheel axis:
The dialog box current selection field is automatically updated.

7.  Select the planes as shown below.
Plane 1: select the left inner hinge plane 
Plane 2: select the left wheel surface

8. Assign the driven angle command if needed.
9. Click Ok to end the Revolute Joint creation. 

The specification tree is updated 



10. Open the Create_Coincidence_Revolute.CATProduct to check your result.

Please refer to Creating Revolute Joints with Offset (Advanced mode) 
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Creating Prismatic Joints
This task shows how to create prismatic joints in a V5 mechanism.

Open the TwoCubes_Without_Joints.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Prismatic Joint icon  from the DMU Simulation Toolbar or select Insert -> New
Joint ->Prismatic from the Menu bar.
The Joint Creation: Prismatic dialog box appears.

3. Click New Mechanism.

The Mechanism is identified in the specification tree.

Now you need to select two lines and two planes

4. Select Line 1 in the geometry area. In our example select an edge (Cube 1)

5. Select Line 2 in the geometry area. Select a second edge (Cube 2)
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The dialog box current selection field is automatically updated.

6.  Select the planes as shown below.

7. Click Ok to end the prismatic joint creation.

The prismatic joint is created and identified in the specification tree



8. Open the TwoCubes_Prismatic_Joint.CATProduct to check your result.
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Creating Cylindrical Joints
This task shows how to create cylindrical joints in V5 mechanism.

Open the TwoCubes_Without_Joints.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Cylindrical Joint icon  from the DMU Simulation Toolbar or select Insert ->
New Joint ->Cylindrical from the Menu bar.
The Joint Creation: Cylindrical dialog box appears.

3. Click New Mechanism.

The Mechanism is identified in the specification tree.

Now you need to select two lines 
4. Select Line 1 in the geometry area. In our example select an edge (Cube 1)
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5. Select Line 2 in the geometry area. Select a second edge (Cube 2)

The dialog box current selection field is automatically updated.

6. Click Ok to end the cylindrical joint creation.

The joint is created and identified in the specification tree

7. Open the TwoCubes_Cylindrical_Joint.CATProduct to check your result.
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Creating Spherical Joints
This task shows how to create spherical joints in a V5 mechanism.

Open the TwoCubes_Without_Joints.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Spherical Joint icon  from the DMU Simulation Toolbar or select Insert ->
New Joint ->Spherical from the Menu bar.
The Joint Creation: Spherical dialog box appears.

3. Click New Mechanism.

The Mechanism is identified in the specification tree.

Now you need to select two points.

4. Select Point 1 in the geometry area. In our example select the vertex (Cube 1)

5. Select Point 2 in the geometry area. Select a second point (vertex Cube 2)
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6. Click Ok to end the spherical joint creation.

The spherical joint is created and identified in the specification tree

7. Open the TwoCubes_Spherical_Joint.CATProduct to check your result.
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Creating Planar Joints
This task shows how to create planar joints in a V5 mechanism.

Open the TwoCubes_Without_Joints.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Planar Joint icon  from the DMU Simulation Toolbar or select Insert ->
New Joint ->Planar from the Menu bar.
The Joint Creation: Planar dialog box appears.

3. Click New Mechanism.

The Mechanism is identified in the specification tree.

Now you need to select two planes.

4. Select Plane 1 in the geometry area as shown below

5. Select Plane 2 in the geometry area. Select a second plane (Cube 2)
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6. Click Ok to end the planar joint creation.

The planar joint is created and identified in the specification tree

7. Open the TwoCubes_Planar_Joint.CATProduct to check your result.
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Creating Rigid Joints
This task shows how to create rigid joints in a V5 mechanism.

Open the TwoCubes_Without_Joints.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Rigid Joint icon  from the DMU Simulation Toolbar or select Insert -> New
Joint ->Rigid from the Menu bar.
The Joint Creation: Rigid dialog box appears.

3. Click New Mechanism.

The Mechanism is identified in the specification tree.

Now you need to select two parts.

4. Select Part 1 either in the specification tree or in the geometry area. In our example, select
Cube 1.

5. Select Part 2 either in the specification tree or in the geometry area. Select Cube 2.
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6. Click Ok to end the rigid joint creation.

The rigid joint is created and identified in the specification tree

 

 



Designing Joints without Assembly Constraints
The following list shows these 5 particular joint types which do not associate assembly constraints during creation:

Point Curve 

Slide Curve 

Roll Curve 

Point Surface 

Universal 

The conditions under which you can create these joints are the following:

Point Curve and Point surface: the point has to be on the curve.
Slide and Roll curves: the two curves are in contact and tangent in this point.
Universal Joint:

Create Point Curve joints: select Insert->New Mechanism... from the menu bar or click the Point Curve Joint icon, then
click New Mechanism in the dialog box displayed. Select one curve and one point and click Ok.

Create Point Surface joints: select Insert->New Mechanism... from the menu bar or click the Revolute Joint icon, then
click New Mechanism in the dialog box displayed. Select one surface and one point, when done click Ok.

Create Roll Curve joints: select Insert->New Mechanism... from the menu bar or click the Roll curve Joint icon, then
click New Mechanism in the dialog box displayed. Select two curves and click Ok.

Create Slide Curve joints: select Insert->New Mechanism... from the menu bar or click the Slide Curve Joint icon, then
click New Mechanism in the dialog box displayed. Select two curves and click Ok.

Create Universal joints:  select Insert->New Mechanism... from the menu bar or click the Revolute Joint icon, then
click New Mechanism in the dialog box displayed. Select two lines and the direction of the cross-pin axis, when done
click Ok.

 

  



Creating Point Curve Joints
This task shows how to create  Point Curve joints in a V5 mechanism.

Open the PointCurve_withoutKin.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box.
Remember though, that you create a mechanism independently from the joints by
selecting Insert->New Mechanism... from the menu bar.

1. Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar
(Revolute joint is the default joint type)

2. Undock the  Kinematic Joints  toolbar:

3.
Select the Point Curve Joint icon .

The Joint Creation: Point Curve dialog box is displayed.
4. Click on New Mechanism.

5. Select Curve 1 in the geometry area. In our example select an edge as shown below:
The current selection field is automatically updated with your selection.

file:///E|/www/fbpdocr5/KinEnglish/kinug.doc/src/samples/PointCurve_withoutKin.CATProduct


6. Select Point 1 in the geometry area. In our example, select the vertex as shown
below:

7. Assign the command, for this Check the Driven length option 

8. Click Ok to end the point curve joint creation.



The specification tree is updated:

9. Define joint 2 and joint 3 as planar joints, the specification tree is updated.
Open the PointCurve_with_Kin.CATProduct  to check your result.
For more information, please refer to About Joints and Creating Mechanisms and
Joints.

10.
Click the Fixed Part icon  from the Simulation toolbar or select Insert->Fixed Part...
from the menu bar.
The New Fixed Part dialog box is displayed.

11. Select the Fixed Part either in the geometry area or in the specification tree. Here,
select Cube 1.

file:///E|/www/fbpdocr5/KinEnglish/kinug.doc/src/samples/PointCurve_with_Kin.CATProduct


The mechanism can be simulated.

12.
Click the Simulation With Commands icon .

The Kinematic Simulation - Mechanism 1 dialog box is displayed.

13.
Manipulate the slider of the command. 

The corresponding mechanism moves accordingly



 

 



Creating Point Surface Joints
This task shows how to create Point Surface joints in a V5 mechanism.

Open the PointSurface_without_Joint.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box.
Remember though, that you create a mechanism independently from the joints by
selecting Insert->New Mechanism... from the menu bar.

1. Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar
(Revolute joint is the default joint type).

2.
Undock the  Kinematic Joints  toolbar:

3.
Select the Point Surface Joint icon .

The Joint Creation: Point Surface dialog box is displayed.
4. Click on New Mechanism.

5. Select Surface 1 either in the geometry area or in the specification tree. 

The current selection field box is automatically updated with your selection.
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6.
Select Point 1 either in the geometry area or in the specification tree.

7. Click Ok to end the point surface joint creation.

The specification tree is updated.

8.
Open the PointSurface_with_Joint.CATProduct document to check your result.

For more information, please refer to About Joints and Creating Mechanisms and
Joints.
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Creating Roll Curve Joints
This task shows how to create Roll Curve joints in a V5 mechanism.

Open the RollCurve_without_kin.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box.
Remember though, that you create a mechanism independently from the joints by
selecting Insert->New Mechanism... from the menu bar.

1. Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar
(Revolute joint is the default joint type).

2. Undock the  Kinematic Joints  toolbar:

3.

4.
Select the Roll Curve Joint icon .

The Joint Creation: Roll Curve dialog box is displayed.
Click on New mechanism.

5. Select Curve 1, in our example, select the inner ring in the geometry area.The
current selection field is automatically updated with your selection.
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6.
Select Curve 2, for instance select the roller as shown below:

7. Click Ok to end the roll curve joint creation.

8. The specification tree is updated.



9
Now, create joint 2. For this select the  Roll Curve Joint icon  again.
The Joint Creation: Roll Curve dialog box is displayed.

10. Select  the outer ring as curve 1 and the roller as curve 2 in the geometry area

11. Click Ok to end the joint 2 (roll curve joint) creation.

The specification tree is updated



12
Now, create joint 3, (revolute joint). For this select the Revolute Joint icon .
The Joint Creation: Revolute dialog box is displayed.

13. Select  the lines and the planes:
Inner ring axis for line 1
outer ring axis for line 2
zx plane (inner ring)
zx plane (outer ring)

14 Assign the command, for this Check the Driven length option 



15 Click Ok to end the revolute joint creation.
The specification tree is updated.

16.
Click the Fixed Part icon  from the Simulation toolbar or select Insert->Fixed
Part... from the menu bar.
The New Fixed Part dialog box is displayed.

17. Select the inner ring as Fixed Part either in the geometry area or in the specification
tree.
The specification tree is updated and the mechanism can be simulated.

Open the RollCurve_with_kin.CATProduct document to check your result.

For more information, please refer to About Joints and Creating Mechanisms and
Joints.
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Creating Slide Curve Joints
This task shows how to create slide curve joints in a V5 mechanism.

Open the SlideCurve_without_kin.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box.
Remember though, that you create a mechanism independently from the joints by
selecting Insert->New Mechanism... from the menu bar.

1. Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar
(Revolute joint is the default joint type).

2.
Undock the  Kinematic Joints  toolbar.

3.
Select the Slide Curve Joint icon .

The Joint Creation: Slide Curve is displayed

4. Click on New Mechanism.

5. Select Curve 1 either in the geometry area or in the specification tree. In our example,
select the Green sphere arc as shown below:

The dialog box is automatically updated with your selection
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6. Select Curve 2 either in the geometry area or in the specification tree. In our example,
select the Yellow sphere arc as shown below:

7. Click Ok to end the slide curve joint creation.

Now create joint 2 (revolute joint) and joint 3 ( prismatic joint)
8. You forgot to assign the Command:

Double-click Joint 2 (revolute joint) in the specification tree  
check the Driven Angle option in the Joint Edition : Joint. 2 dialog box displayed
When done, click Ok



Open the SlideCurve_ with_kin.CATProduct  to check your result.

For more information, please refer to About Joints, Creating Revolute Joints and
Creating Prismatic Joints.

This is what you obtain:

Click the Fixed Part icon  from the Simulation toolbar or select Insert->Fixed Part...
from the menu bar.
The New Fixed Part dialog box is displayed.

Select the Fixed Part either in the geometry area or in the specification tree. Here,
select the Green sphere.
The specification tree is updated.
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The mechanism can be simulated

Click the Simulation With Commands icon .

The Kinematic Simulation - Mechanism 1 dialog box is displayed.

Manipulate the slider of the command



 

  



Creating Universal Joints
This task shows how to create Point Surface joints in a V5 mechanism.

Open the UJoint_without_joint.CATProduct document.

When you create joints, you can define the mechanism within the same dialog box.
Remember though, that you create a mechanism independently from the joints by
selecting Insert->New Mechanism... from the menu bar.

1. Click the arrow within the Revolute Joint icon from the DMU Kinematics toolbar
(Revolute joint is the default joint type)

2. Undock the  Kinematic Joints  toolbar:

3.
Select the Universal Joint icon .

The Joint Creation: Universal Joint dialog box is displayed.

4. Click on New Mechanism.
5. Select Line 1 either in the geometry area or in the specification tree. In our

example, select the green cylinder axis as shown below:
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The current selection field is automatically updated.

6. Select Line 2, for example the blue cylinder axis:

7. Select the direction of the cross-pin axis (which has to be perpendicular with one of
the two axis previously selected). In our example, select an edge of the green
cylinder.

8.
Click Ok to end the Universal joint creation.



The tree is updated

9.
Open the Ujoint_with_joint.CATProduct to check your result.

For more information, please refer to About Joints and Creating Mechanisms and
Joints.
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Running Simulations
DMU Kinematics Simulator provides easy methods to run kinematics simulations and detect
collisions during simulations.

Defining  Laws in a V5 Mechanism
Simulating With Laws

Simulating With Commands
Simulating On Request

Manipulator symbols are displayed for either translating or rotating the mechanism
whenever its joints have associated commands.

For a joint with a linear command, a linear manipulator symbol is displayed. To
translate the mechanism just drag it using the left mouse button.
For a joint with an angular command, a circular manipulator symbol is displayed.
To rotate the mechanism just drag it using the left mouse button.
For a joint with linear and angular commands, a linear manipulator symbol is
displayed. To translate the mechanism just drag it using the left mouse button.
To access the circular manipulator for rotating the mechanism you must use the
left and middle mouse buttons together and drag as before.

 

  



Defining Laws in a V5 Mechanism
This task will show you how to define laws based on Knowledgeware features allowing time-based simulations

You need a V5 mechanism you can simulate. Please refer to Designing a V5 Mechanism 

Open the DEFNE_LAWS.CATProduct document.

Use the Fit All In icon  to position the model geometry on the screen.
(Optional)
Make sure the relations node will be
displayed in the specification tree.

Activate the relations option display,
for this:

Select Tools->Options from
the menu bar.
The Options dialog box is
displayed
Expand the Infrastructure
category from the  tree
Select Product Structure item
in the tree 
Click the Product Structure
tab
Activate the Relations option.

1.
Click the Simulation With Laws icon  in the DMU Kinematics toolbar.
The Kinematic Simulation dialog box appears:

 

You need to define at least one relation between a command and the Time parameter, let's create this relation
referred to as law throughout this scenario.

2. Click the Close button to exit the dialog box.
You are going to create a law using
the existing
command.1(joint.1,Angle)
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3.
Click the Formula icon from the Knowledge Toolbar. The "Formulas" dialog box is displayed.
The 'Incremental' box must be unchecked.

  Select Mechanism 1 in the specification tree to obtain quickly the parameters specific to your Mechanism
document.

3. Double-click the Mechanism.1\listcmd\Command.1\Angle parameter.
The Formula Editor dialog box appears:

4. Click the Wizard button and select Time in the Members of Parameters list.



5. Click Mechanism.1\KINTime in the Members of time list.

6. Enter /1s*36deg after Mechanism.1\KINTime to complete the formula. 

When done click OK to exit the Formula Editor dialog box.

7. The Formulas dialog box is updated,
Click Ok to end the formula creation.

The relation is created and identified in the specification tree both under the:
Relations item
Laws item



The Mechanism can be simulated with laws. Please open USE_LAWS.CATProduct to check your result.

8.
Click the Mechanism Analysis icon  from the DMU Kinematics toolbar.

Click  in the Mechanism Analysis dialog box displayed.
The laws display dialog box appears:

For more information, see the Knowledge Advisor User's Guide.
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Simulating With Laws
This task will show you how to run a kinematics simulation with laws that are already
defined on the mechanism.

Insert the KIN_EX17* .model files from the samples folder.

1.
Click the Simulation With Laws icon  in the DMU Kinematics toolbar

 

2. Set the desired Number of steps, then run the simulation using one of the VCR
buttons:

Start
Play Back
Step Back
Pause
Step Forward
Play Forward
End.

The kinematics mechanism moves according to the pre-defined laws.

You can switch between any of the simulation modes at any time.
You can also enter a time value to visualize the position of the mechanism at that
time.

3. Click Analysis if you need to detect interferences or distances while simulating (you
need to create interference or distance objects first )
The Analysis Studies dialog is displayed.

4. Click add to display the Select dialog box.



5. Select the interference if you define one  and set to the interference combo to on.
6. Run the simulation.

For more details, please refer to Detecting Interferences and Detecting Distances.

  Notice that you cannot record simulations within the Simulation With Laws
functionality. If you need to record such a simulation or several simulations, please
refer to Recording Positions.

 

  



Simulating With Commands
This task will show you how to run a kinematics simulation with commands.

Insert the KIN_EX17* .model files from the samples folder.

If you work with the Cache System, please make sure you are in Design mode (select
Edit->Representations->Design Mode.). for more detailed information, please refer to
the DMU Navigator user's Guide - Task: Viewing the Cache Content.

. In our sample document, there is only one mechanism. If you work with a product
containing more than one mechanism, it is strongly recommended to select the
mechanism you need before starting the simulation with commands.

1. Click the Simulation With

Commands icon .

The Kinematic Simulation dialog
box appears:

Click the Less button if
necessary.
Note: the state of the dialog box
depends on your settings.
The commands of the
kinematics mechanism are
available as shown opposite.

2. Manipulate the slider of a command. For instance select the LEFT command.
The corresponding part of the kinematics mechanism moves accordingly.

Note that if you click the  button, the Kinematic Simulation dialog box expands.
The immediate option is set by default. For more information about the On request
option, please refer to  Simulating on Request



You can use the slider, enter a value or manipulate the geometry directly to achieve the
same result.

3. Manipulate the other commands in the same way.

You can set a command
value directly in the spin box.

You can also set lowest and
highest values for the range
of a command by clicking on
the button opposite the
command and entering
values in the displayed
pop-up.
You cannot record your simulation within the Simulation With Commands command.
You can record simulations within the Simulation command (please refer to Recording
Positions).

  



Simulating On Request
This task shows how to perform a simulation on request.

Insert the KIN_EX17* .model files from the samples folder.

If you work with the Cache System, please make sure you are in Design mode (select
Edit->Representations->Design Mode.). for more detailed information, please refer to the DMU Navigator user's
Guide - Task: Viewing the Cache Content.

. In our sample document, there is only one mechanism. If you work with a product containing more than one
mechanism, it is strongly recommended to select the mechanism you need before starting the simulation with
commands.

1.
Click the Simulation With Commands icon .
The Kinematics Simulation dialog box is displayed .

2. Click 

The commands of the kinematics mechanism are available as shown below.

By default, the Immediate option is set

3. Activate the On Request option.

If you run the simulation without changing at least one command value the following message displays:



4. Enter values for the various commands. For instance:
5. 20 for the OPENING command

50 for the LEFT command
30 for the INCLINAT command
40 for the LANDING command

Enter the number of steps you need, 20 for example.

 

6.  Click Play Forward.

The corresponding parts of the kinematics model move accordingly at each step.
You can modify values of one or more commands for each motion.

 

 



Reviewing Simulations
DMU Kinematics Simulator provides easy methods to record and replay kinematic simulations.

 

Recording Positions
Replaying Simulations

Detecting Clashes Automatically

 

  



Recording Positions
This task shows how to record positions of a kinematics mechanism.

Insert the KIN_EX17* .model files from the samples folder.
At least one kinematics mechanism must be active in the specification tree.

1.
Click the Simulation icon .

The Select dialog box is displayed.

2. Select LANDING GEAR and click OK.

Kinematic Simulation and Edit Simulation
dialog boxes appear. A Simulation object
is created in the specification tree.

3. Click the Insert switch and record the starting position.
Insert means that you record and insert positions inside the scenario.



4. Move the mechanism (using the manipulators or sliders, for example), then Click the Insert switch
again.

5. Record as many positions as necessary.
6. Use the VCR buttons to replay the recorded positions.

This type of record can be used to simulate several mechanisms simultaneously.

 

 



Replaying Simulations
This task shows you how to create a traction on a geometry of a part.

Insert the KIN_EX17* .model files from the samples folder. See Recording Positions.
You then compiled the Simulation created as described in the previous task. Please
refer to Compiling a Simulation in the DMU Fitting Simulator User's Guide

 

1. Activate the Simulation object in the specification tree.
2.

Click the Replay icon  .
The Replay dialog box is displayed.

3. Specify the desired speed  for instance x 5.
4. Click:

the Play VCR button to run a continuous replay of the recorded motion
or the Forward VCR button to run a step-by-step of the recorded motion.

Each motion is replayed one after the other in the order they were recorded.

You can choose one of the loop modes to re-run the simulation in a continuous way
(either in the one direction only or in one direction then the other).

 



  



Detecting Clashes Automatically
This task shows you how to use the Clash Detection functionality while performing a Kinematics
simulation.
Open AUTO_CLASH_DETECTION.CATProduct document.

 

1.
 Click the Simulation With Commands icon  from the DMU Kinematics toolbar.
The Kinematic Simulation dialog box is displayed. Select GARDENA as mechanism.

2. Click  to expand the dialog box. 
3. Activate the On request mode.

4.
Click the arrow within the Clash Detection icon   from the DMU Generic Animation toolbar.
Undock the toolbar if necessary.

file:///E|/www/fbpdocr5/KinEnglish/kinug.doc/src/samples/AUTO_CLASH_DETECTION.CATProduct


5.
Set the Clash detection to on 

6. Move slider to 116 for command 3 (C3)
7.  Run your simulation

The products in clash are highlighted in the geometry area

Now set the clash detection on Stop mode .
8. Run your simulation.This time, the simulation stops at the first clash detected.

If you need to obtain a finer clash analysis, you need to define a interference, please refer to Detecting
Interferences

 



 



Managing the Mechanism Dress-up
This task shows how to dress-up mechanisms.

Open the MANAGING_DRESSUP.CATProduct document.
At least one kinematics mechanism must be active in the specification tree.

You no longer need to select Edit->Representations->Design Mode as it is automatically activated. DMU
Kinematics Simulator finds the product containing kinematics objects automatically. This new capacity is available
for all Kinematics commands (simulation...)

1.
Click the Mechanism Analysis icon .
The Mechanism Analysis dialog box displays:

2.
Click on the Simulation With Commands icon .
The Kinematic Simulation dialog box is displayed.
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3. Manipulate the slider of the LEFT command.
The corresponding part of the kinematics mechanism namely the Opening moves accordingly.

4. Click  and then .

Let's attach the left door to the LANDING GEAR mechanism:
5.

Click the Mechanism Dress-up icon  from the DMU Simulation Toolbar.
The Mechanism Dress-up dialog box  is displayed.

6. Select  LEFT DOOR as link.
Note you can select the link directly in the geometry area or in the specification tree, using the the graphic
selection option. Though, only one selection is allowed.

Note that you can select or deselect attachments directly from the specification tree or geometry area.

You can now select either the available products or all products. By default the Available products option is set.



Available products: if set, this option lets you visualize the products that are not referenced in any
attachment  within the mechanism.
All Products: if set, this option lets you visualize the products that are not attached to the current link (here,
LEFT DOOR)

7. By default the Available products option is set:
The two products in the left column have not been attached yet. 

8. If you set the All products option this is what you obtain
Now, select  The KIN_EX17_09_DOOR from the available products list to attach it to the link:

The  selected product is highlighted in the specification tree and in the geometry area as shown below:

9. Click OK to confirm your operation.



Let's simulate the mechanism with the new dressup
10.

Click on the Simulation With Commands icon  again.
11. In the Kinematic Simulation dialog box, manipulate the slider of the LEFT command.

This time, the corresponding part of the kinematics mechanism moves accordingly.

The Simulation With Commands capability is only used to simulate. If you need to record the simulation use the
Simulation functionality.

 

 



Advanced Tasks
 

DMU Kinematics Simulator provides easy methods to detect and analyze collisions and
distances between products. It also provides the capacity of generating a swept volume.
The DMU Space Analysis Version 5 product must be installed before using these
functionalities.

 

Creating Revolute Joints with Offset (Advanced Mode)
Creating Revolute Joints With Centered Option

Using the Trace Command
Converting Constraints into Joints (Advanced Mode)

Detecting Collisions and Distances
Analyzing a Mechanism

Defining a Swept Volume

 



Creating Revolute Joints With Offset 
(Advanced Mode)

 
This task shows how to create offset revolute joints or centered revolute joints

Open the Create_Revolute.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Revolute icon  from the DMU Simulation Toolbar or select Insert -> New Joint ->Revolute
from the Menu bar.
The Joint Creation: Revolute dialog box appears:

3. Click New Mechanism.
The Mechanism is identified in the specification tree.

5. Select the lines in the geometry area  :
Line 1 = hinge axis
Line 2 = wheel axis

6.  Select the planes in the geometry area:
Plane 1 = left inner hinge plane
Plane 2 = left wheel axis surface
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7. Activate the Offset option. 
Select the offset value for this, three methods are available:

enter the required value in the offset field 
use the scrollbar
right-click the field and select the measure item from the contextual menu displayed

In our example keep the default value.
If you perform a right-click in the offset value field, a contextual menu lets you select between two items:
measure or change step

Select the measure item: 

The Measure Between dialog box and measure Tools toolbar appear

Set the measure type and mode, then select two entities. Keep this measure as offset value. A warning
message lets you copy the measure you defined.



You can also change the step using Change step->new one
For more information, see Specifying a Parameter Value as a Measure in the Knowledge Advisor User's
Guide and Measuring Minimum Distances & Angles between Geometrical Entities and Points in the
Space Analysis User's Guide

8. Assign the driven angle command if needed.
9. Click Ok to end the Revolute Joint creation. 

The specification tree is updated.

Open the Create_Revolute_Offset.CATProduct to check your result.
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Creating Revolute Joints 
(Centered Option)

This task shows how to create offset revolute joints or centered revolute joints

Open the Create_Revolute.CATProduct document.

1. Make sure you are in Design mode. If not, select the product in the tree, then select
Edit->Representations->Design Mode.
If the menu item cannot be selected, right-click product1 in the specification tree.

2.
Click the Revolute icon  from the DMU Simulation Toolbar or select Insert -> New Joint ->Revolute
from the Menu bar.
The Joint Creation: Revolute dialog box appears:

3. Click New Mechanism.
The Mechanism is identified in the specification tree.

4. Activate the Centered option. 
5. Select the lines in the geometry area  :

Line 1 = hinge axis
Line 2 = wheel axis

file:///E|/www/fbpdocr5/KinEnglish/kinug.doc/src/samples/Create_Revolute.CATProduct


6.  Select the planes in the geometry area:
Plane 1 = left inner hinge plane
Plane 2 = left wheel axis plane
Plane 3 = right inner hinge plane
Plane 4 = outer wheel plane

8. Assign the driven angle command if needed.
9. Click Ok to end the Revolute Joint creation. 

The specification tree is updated.



Open the Create_Revolute_Centered.CATProduct to check your result.
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Using the Trace Command
Part Design and Generative Shape Design  Licenses:
You can use this capability only if you have a Part Design or/and a Generative Shape
Design  license
This task explain how to use the generate a trace of a point for design purposes. This
is very useful in the design process as you can use the resulting trace to design cams.
Open the Create_Trace.CATProduct document.
A simulation is recorded and compiled into a Replay object.

1. Make sure you are in Design mode if you work with the Cache System (please refer
to DMU Navigator User's Guide- Viewing the Cache Content)
If not, select Edit ->Representations->Design Mode from the menu bar..

2.
Click the Trace icon   from the DMU Generic Animations toolbar.
The Trace dialog box appears:

3. Select a point to trace either in the geometry area or in the specification tree.
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4. Click Ok to end the trace creation.

If the Reference product is a not a Part, the trace destination is a New Part document
as you cannot only write into a part document.

The trace is created in a New Part and looks like this:



5. Copy your resulting trace into your initial document, for this use the copy/ paste
capability.



6. The trace is identified both in the specification tree and in the geometry area

7. Now, Run the replay step by step. For this: select Replay in the specification tree and
double click replay1.

8.
 Click the Trace icon   again.

9. Expand the Slide node and select point 2 in the
specification tree as point to trace. 



8. Select Cog-Wheel.1 as Reference product

10. Select the trace destination (Reference Product) when done, click Ok.
The trace appears in the geometry area in the part select ( Cog-Wheel.1) 

11. Now, Run the replay step by step. For this: select Replay in the specification tree and
double click replay1.

 

  



Converting Constraints Into Joints 
(Advanced Mode)

This task shows how to convert constraints into joints in advanced mode

Open the jigsaw_with_constraints.CATProduct document.
The constraints are visible both in the geometry area and in the specification tree.

1. Make sure you are in Design mode if you work with the Cache System (please refer
to DMU Navigator User's Guide- Viewing the Cache Content)
If not, select Edit ->Representations->Design Mode from the menu bar..

Click the Joints from Assembly icon  from the DMU Kinematics toolbar.
The Assembly Constraints Conversion dialog box appears:

2. Click on the New mechanism button.
3. Click the   button.

The Assembly Constraints Conversion dialog box expands:
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Let's look at this dialog box more carefully:

 : specifies the status of the product pairs

Shows the pair comprising of two products (Ring.1 and Cog-Wheel). You are dealing
with the first pair (1/5).
The Constraints list displays: 

the name and type of the constraints,
the elements type and detailed information about the first and second element.

The joints and Fix constraints lists display the same kind of information.
Run the Assembly constraints conversion using one of the VCR buttons:

 : lets you step forward.

 : lets you go to next unresolved pair.

 : lets you go to the last pair.
4. Click Create Fix to create the fixed part



The fixed part is visible in the Current Fixed Part field. 

The Fixed part is identified in the specification tree and highlighted in the geometry area.

Note that when you have several fix constraints in your assembly, you can create a rigid
joint between each of them. When this is the case, the following warning is displayed:

You are now ready to convert assembly constraints into joints for the first pair of products
namely  Ring.1and Cog-wheel 1

5. Multi-select Coincidence.27 and Coincidence.18 in the Constraints list (use Crtl Key +
left mouse button). The Create Joint button is no longer grayed out.

6. Create the command

If you forgot to create the command you can still do it. All you need to do is double-click
the joint you want to be assigned a command in the Joint list and check the driven angle
option in the Edit joint dialog box displayed.



Click Ok. The following information message is displayed:

7. Click  ( the resulting type is specified in the resulting type field).
The Joint list is updated. if you are not satisfied, click the Delete Joint button.
The Revolute joint and command are identified in the specification tree and highlighted in
the geometry area

8.  Proceed in the same manner to convert the remaining assembly constraints into joints.
Click OK to confirm your operation.
The mechanism can now be simulated.



9.
Click the Simulation with commands icon  from the DMU Kinematics toolbar.
Please refer to Simulating With Commands.

 

  



Detecting Collisions and Distances
Calculate Distances: select two items, then click the Distance icon. Select the required
settings in the Edit Distance dialog box and click Ok. Double-click  the Simulation.1
and click the Edit Analysis button. Click Add then select Distance1 from the displayed
pop-up, set the Distance combo to On and replay your simulation.
Detect Clashes: select two items, then click the Clash icon. Select the required
settings in the Check clash dialog box and click Ok. Double-click  the Simulation.1 and
click the Edit Analysis button. Click Add then select Interference1 from the displayed
pop-up, set the Interference combo to On and replay your simulation.

 

  



Calculating Distances
This task shows how to calculate distances between two products.

Insert the KIN_EX17* .model files from the samples folder.
The kinematics document must be already opened.
You already defined a simulation. For more information, please refer to Recording
Positions.

1. In the specification tree, click KIN_EX17_06_CENTRAL_DOOR then control-click
KIN_EX17_09_LEFT_DOOR.
The two items are selected and highlighted in the specification tree.

2.
Click the Distance and Band Analysis icon  in the DMU Space Analysis toolbar, or
select Insert -> Distance from the menu bar to calculate distances:
The Edit Distance And Band Analysis dialog box is displayed. 



3. Ensure that the first Type drop-down list box is set to Minimum and Inside one
selection.

The default distance analysis is measuring the minimum distance inside one selection.

4. Click OK.

The specification tree is updated.

5. Double-click  the Simulation.1 in the
specification tree.

The Edit Simulation dialog box is displayed.

6. Click the Edit Analysis button.

7. The Edit Analysis In Simulation dialog box is
displayed: 



Click Add then select Distance1 from the
displayed pop-up.

The Edit Simulation dialog box is updated.
8.

Set the Distance combo to On in the Edit
Simulation dialog box.

The specification tree is updated.
9. In the Kinematics Simulation dialog box, run

a step by step simulation using the Use Laws
tab.

The minimum distance between the two
products is displayed at each step.

Please refer to the DMU Space Analysis User's Guide for more information about
detecting and analyzing distances between products or between groups.

 



 



Detecting Clashes
This task shows how to detect clashes between two kinematics products.

Open the DETECT_CLASHES.CATProduct document.

1. In the specification tree, click KIN_EXT17_01_ENS.1.1 then control-click
KIN_EXT17_09_LEFT_DOOR.
The two items are highlighted in the specification tree and in the geometry area.

2. Click the Clash icon  .
The Check Clash dialog box is displayed. Make sure the interference type is set to Contact + Clash
and Inside one selection.
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3. Click Apply, when done Ok.
The specification tree is updated.

4. Double-click Simulation.1 in the specification tree. 
The Edit Simulation and Kinematic Simulation dialog boxes are displayed.

5. Click Edit Analysis in the Edit Simulation dialog box.

The Edit Analysis in Simulation dialog box is displayed.

6. Click Add then select interference 1 from the displayed
Select dialog box

The Edit Analysis in Simulation dialog box is updated as
shown opposite:



7. Click OK to confirm your operation.
You defined an interference.

8. Set the Interference combo to On.

The specification tree is updated.

9. To locate the clash position more precisely,  set the Interference combo to Stop  in the Edit
Simulation dialog box

The simulation stops at the position where a collision is
detected between the ENS1 and the LEFT DOOR
products.

The products in collision is highlighted.

 



10. Click Edit Analysis in the Edit Simulation dialog box.
The Edit Analysis in Simulation appears.

11. Click Browse.

12. The Check Clash dialog box is displayed.

The specification tree is updated.

Please refer to the DMU Space Analysis User's Guide for more information about detecting and
analyzing interferences between products or between groups.

 

 



Analyzing a Mechanism
This task shows how to analyze a mechanism using the Mechanism Analysis dialog
box
The kinematics document must be already opened.
Insert the KIN_EX17* .model files from the samples folder.

1.
Click the Mechanism Analysis icon .
The Mechanism Analysis dialog box is displayed.
It lets you access information about each joint in the kinematics mechanism, you can
see which joint is assigned a command for instance.
The following mechanism components are detailed under the following characteristics:

Command
Type: revolute, prismatic, spherical...
Part1: first part upon which the joint is based.
Geometry: geometry associated to the part



If you defined a new mechanism, when you delete a part including in the mechanism
the corresponding joint is no longer valid. The message invalid joint! appears in the
Mechanism Analysis dialog box.

2. Click the LEFT command. The Mechanism dressup information displays
The products are highlighted both in the 3D and in the specification tree.



 

  



Defining Swept Volume
Define a Swept Volume: click the Swept Volume icon from the DMU Generic Animation toolbar, then select a
product to sweep using the more button to display the Multi-selection dialog box. Click Apply to generate the
swept volume. When done, click Ok to save your swept volume in cgr format.
Define a Swept Volume from a Moving Reference: click the Swept Volume icon from the DMU Generic
Animation toolbar, then select a product to sweep and a reference product. Click Apply to generate the swept
volume. When done, click Ok to save your swept volume either in wrl or cgr format.
Filter Swept volume Positions: click the Swept Volume icon from the DMU Generic Animation toolbar, then
select a product to sweep using the more button to display the Multi-selection dialog box, then check the Filter
Positions option and enter a value in the Filtering precision field. Click Apply to generate the swept volume.
When done, click Ok to save your swept volume in cgr format.

 

 



Defining A Swept Volume
This task shows how to generate a Swept volume. 

You recorded a simulation in a Simulation object and compiled the Simulation. You
obtained a Replay object. You need this Replay object to define a swept volume.
Open the KIN_SWEPT_VOL.CATProduct document.

1.
Click the Swept Volume icon .
The Swept Volume dialog box is displayed.

 Note: the Filter Positions option is checked by default
3. Click in the Product to sweep spin box, the selection list dialog box lets you select or

deselect the bodies you want to sweep.
4. Select KIN_EX17_03_ENS3.1
5. Click OK.

6. Click Apply to generate the swept volume
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The progress bar is displayed letting you monitor and, if necessary, interrupt  (Cancel
option) the calculation.

 

7. If you check the Use level of details option,
This what you obtain:

8. Click Ok.
The Save As dialog box appears:
Note  you can also save your result in vrml (wrl). 



 

9. Select cgr and click Save.
10. Insert the SWEPTVOLUME_absoluteresult.cgr into Product1, for this right-click

Product1 and select Components-> Existing component from the contextual menu
displayed. 
The Swept volume is identified in the specification tree and in the geometry area

 

 



Defining a Swept Volume from a Moving
Reference

This task shows how to define a swept volume using a moving reference. See the previous task.
In our example you need to obtain a finer result to analyze clashes, if any.

Open the KIN_SWEPT_VOL.CATProduct document.

1.
Click the Swept Volume icon .
The Swept Volume dialog box is displayed.

2. Uncheck the Filter Positions option as shown below: (the Filter Positions option is checked by
default)

3. Click in the Products to sweep spin box, the Product Multiselection dialog box lets you select or
deselect the bodies you want to sweep.

4. Select KIN_EX17_03_ENS3.1 from the list.
5. Click Ok.
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6. Click in the Reference Product spin box, the Reference Product Selection lets you select the
reference product.

7. Select KIN_EX17_01_ENS1.1

8. Click Apply to generate the swept volume.
The Computation is in progress:
The progress bar is displayed letting you monitor and, if necessary, interrupt  (Cancel option) the
calculation.

9. Click Ok.



The Save As dialog box appears automatically and lets you save your swept volume in wrml (the
file extension is wrl) or cgr format. 

10. Select cgr format and click Save.

11. Insert the SWEPTVOLUME_relativeresult.cgr into KIN_EX17_01_ENS1, for this right-click  and
select Components->Existing Component from the contextual menu displayed.

The Swept volume is identified in the specification tree and in the geometry area.

 

  



Filtering Swept Volume Positions
This task shows how to filter swept volume positions. It can be very useful in terms
of calculation performances to retrieve positions in a swept volume.  Please refer to
Defining a Swept Volume
You recorded a simulation in a Simulation object and compiled the Simulation. You
obtained a Replay object. You need this Replay object to define a swept volume.
Open the Open the KIN_SWEPT_VOL.CATProduct document.

1.
Click the Swept Volume icon .
The Swept Volume dialog box is displayed.

2. Click in the Products to sweep spin box, the selection list dialog box lets you select
or deselect the bodies you want to sweep.

3. Select KIN_EX17_03_ENS3.1

4. Click OK.
5. Enter 20mm as filtering precision value.
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6. Click Apply to generate the swept volume

The progress bar is displayed letting you monitor and, if necessary, interrupt 
(Cancel option) the calculation.

This what you obtain:



7. Click Ok.
The Save As dialog box appears automatically and lets you save your swept
volume either in vrml (file extension is wrl) or cgr format.



8. Select cgr format and click Save.

Insert the SWEPTVOLUME_filterresult.cgr into Product1, for this right-click
Product1 and select Components->Existing Component from the contextual menu
displayed.
The Swept volume is identified in the specification tree and in the geometry area

Please refer to the DMU Optimizer User's Guide for more information

 

 



Workbench Description
This section contains the description of the icons and menus which are specific to the DMU Kinematics
Simulator Version 5 workbench.

The DMU Kinematic Simulator  window looks like this (click the sensitive areas to see the related
documentation):

Menu Bar
DMU Kinematics Toolbar

Simulation Toolbar
DMU Kinematic Joint Toolbar

DMU Generic Animation Toolbar
Automatic Clash Detection Toolbar

DMU Space Analysis Toolbar



 



DMU Kinematics Simulator Menu Bar
Here we will present the various menus and menu commands that are specific to DMU

Kinematics Simulator Version 5.

Start File Edit View Insert Tools Analyze Windows Help

 
 Tasks corresponding to General menu commands are described in the DMU Version 5
Infrastructure User's Guide.

Edit
For... Description...

Undo Cancels the last action.

Redo Recovers the last action that
was undone.

Cut
Copy
Paste
Paste Special

Performs cut
copy
paste and
special paste operations.

Delete Deletes selected geometry.

Search Allows searching and selecting
objects.



Links Manages links to other
documents.

Properties Allows displaying and editing
object properties.

Insert
 

For... See...

New Mechanism Creating a
Mechanism and
Revolute Joints

New Joint

Creating a
Mechanism and
Revolute Joints

About Joints

Designing Joints
With Assembly
Constraints

Designing Joints
Without Assembly
Constraints

Fixed Part
Defining a Fixed
Part

Simulation Recording Positions

Clash
Detecting
Interferences

Distance Detecting Distances



Existing
Component

Entering the DMU
Navigator
Workbench and
Selecting Models

 

 



DMU Kinematics Toolbar
The DMU Kinematics toolbar contains a number of tools that are useful for DMU Kinematics
Simulator.

 

 
See Simulating with Commands

See Managing the Mechanism Dressup

See Creating a Fixed Part

See Creating a Mechanism and Revolute Joints
See Creating Revolute Joints 
See Creating Revolute With Offset
See Creating Revolute Joints With Centered Option

See Analyzing a Mechanism

 

  



Simulation Toolbar
 

 
See Simulating with Commands
See Detecting Clashes Automatically

See Simulating With Laws
See Defining Laws in a V5 Mechanism

 

 
 

  



Kinematic Joints Toolbar
The Kinematic Joint toolbar contains the various types of joints you can create in Kinematic
Simulation version 5.

 

 
See Creating Revolute Joints 
See Creating Revolute With Offset
See Creating Revolute Joints With Centered Option

See About Joints and Creating Prismatic Joints

See Creating Cylindrical Joints

See About Joints and Creating Spherical Joints

See About Joints and Creating Planar Joints

See About Joints and Creating Rigid Joints

See About Joints and Creating Point Curve Joints

See About Joints and Creating Slide Curve Joints

See About Joints and Creating Roll Curve Joints

See About Joints and Creating Point Surface Joints

See About Joints and Creating Universal Joints

 

  



DMU Generic Animation Toolbar

 

 

 
See Recording Simulations

See Replaying Simulations

See Detecting Clashes Automatically

See Defining a Swept Volume
See Defining a Swept Volume from a Moving Reference
See Filtering Swept Volume Positions
See Using the Trace Command

 

  



Automatic Clash Detection Toolbar

 

 

  See Detecting Clashes Automatically

See Detecting Clashes Automatically

See Detecting Clashes Automatically

 

  



DMU Space Analysis Toolbar

 

 
See Detecting Distances .

See Detecting Interferences .

 



Glossary
C

cable joint A cable type joint between three products (two products are mobile,
the other is a reference). Number of degrees of freedom is 1
(translation).

cylindrical joint A translation type joint between two products along an axis with a
rotation about that axis. Number of degrees of freedom is 2 (1
translation and 1 rotation). This joint was called Actuator in Version 4.

command An angular or linear command that drives the kinematics mechanism.
CV joint A constant velocity joint between two products. Number of degrees of

freedom is 4 (comprises two U joints).

D
degrees of freedom The number of possible independent rotation or translation

movements of a joint.
dress up A list of models attached to a set of the kinematics model. These

models have the same motion as the set.

F
fixed product The product that remains stationary when the kinematics mechanism

is in motion.

G
gear joint A gear type joint between three products (two products are pinions,

the other is a reference). Number of degrees of freedom is 1
(rotation).

J
joint A constraint between geometric entities of two or three products.

There are several types of joint.
joint stop An imposed limit applied to a joint.

K
kinematics mechanism A mechanism comprising several products that are connected by

joints.

It can be simulated when the number of commands is equal to
degrees of freedom (in this case the mechanism is said to be
complete).



kinematics product A rigid product defined in a single geometric set that contains all the
elements required to describe the kinematics mechanism and its
motion.

kinematics simulation A simulation of the mechanism's motion using commands. Simulation
can be immediate (commands are used one by one) or on request
(one or more commands are used with a given number of steps).

L
law A numeric or graphic representation of the commands applied to a

kinematics mechanism as a function of time.

P
planar joint A planar joint between two products. Number of degrees of freedom is

3 (1 rotation and 2 translations).
prismatic joint A translation joint between tow products along an axis with no rotation

about that axis. Number of degrees of freedom is 1 (translation).
PT/CRV joint A point/curve joint between two products. Number of degrees of

freedom is 4 (3 rotation and 1 translation) for a 3D mechanism and 2
(1 rotation and 1 translation) for a 2D mechanism.

PT/SUR joint A point/surface joint between two products. Number of degrees of
freedom is 5 (3 rotations and 2 translations).

R
rack joint A gear/rack type joint between three products (one product is the

rack, another is the rack, the other is a reference). Number of degrees
of freedom is 1 (combined translation and rotation).

revolute joint A revolute joint about an axis between two products with no
translation along that axis. Number of degrees of freedom is 1
(rotation).

rigid joint A rigid (fully restricted) joint between two products. There are no
degrees of freedom associated to this joint.

roll/CRV joint A rolling type joint between two products that include curves. There is
no sliding motion with this type of joint. Number of degrees of freedom
is 2 (1 rotation and 1 translation) for a 3D mechanism and 1
(translation) for a 2D mechanism.

S
screw joint A screw/nut type joint between two products relative to an axis.

Number of degrees of freedom is 1 (combined translation and
rotation).



slid/CRV joint A rolling type joint with a sliding motion between two products that
include curves. Number of degrees of freedom is 3 (2 rotations and 1
translation) for a 3D mechanism and 2 (1 rotation and 1 translation)
for a 2D mechanism.

spherical joint A spherical joint between two products. Number of degrees of
freedom is 3 (3 rotations) for a 3D mechanism and 1 (rotation) for a
2D mechanism. This joint was called PT/PT in Version 4.

storyboard A recorded kinematic motion.

U
U joint A universal joint between two products. Number of degrees of

freedom is 2 (2 rotations).



Index
A

Automatic
Clash Detection Toolbar 

C
cable joint 
Clash icon , 
command 
CV joint 
cylindrical joint 

D
degrees of freedom , 
detecting

clash between products 
distance between products 

displaying
joints , 
progress indicator 

Distance icon , 
DMU Generic Animations toolbar 
DMU Kinematics toolbar 
DMU Space Analysis toolbar 
dress up 



E
Edit Simulation dialog box , 

F
fixed product 
fully restricted joint

 

G
gear joint 

J
joint 
joint stop 

K
kinematic mechanism 
kinematic product 
kinematic simulation 
Kinematics Simulation dialog box , , 

L
law 



M
manipulator

for rotating 
for translating 

P
planar joint 
prismatic joint 
PT/CRV joint 
PT/SUR joint 

R
rack joint 
recording

simulation 
Replay dialog box 
Replay icon , 
replaying

simulation 
revolute joint 
rigid joint 
roll/CRV joint 

S
screw joint 
simulating

using commands 
using laws 

slid/CRV joint 
spherical joint 
storyboard 



T
Simulation icon , , , 

U
U joint 

V
Version 4 model 
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